Skip Navigation

[Resolved] Using a view in a content template like a page builder – no posts

This thread is resolved. Here is a description of the problem and solution.

Problem:

Display a content template with PHP codes.

Solution:

Create a content template(ID: 123), design it with blocks editor, setup the static contents.

<?php echo render_view_template( 123); ?>

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 36 replies, has 3 voices.

Last updated by martinE-4 8 months, 2 weeks ago.

Assigned support staff: Luo Yang.

Author
Posts
#1544139

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Sorry for the delay answer, I can duplicate the both problems even without GP premium plugin, with only Toolset plugins + 2020 theme, by putting the function into footer.php directly, I am escalating both issues, will update here if there is any news.

#1545483

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Escalated, will update here if there is any news.

#1563381

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Here is the feedback from our developers, it is fixed in next version of Toolset plugins: Views 3.2 / Blocks 1.2 plugins, which will be release soon, maybe next week.

#1564811

Thanks Luo, this is fantastic news. Thanks for sticking with me in understanding this issue! I am happy to be part of making Toolset Views a better product, particularly using it as a page builder!

#1613383

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

The new Toolset Views/Blocks plugins are released, you can download them here:
https://toolset.com/account/downloads/

Please test and feedback if the problem is fixed, thanks

#1617745

My issue is resolved now. Thank you! The new Views update fixed it!

#1624611

Luo, I am sorry there must still be a problem. I thought I checked this out properly but apparently I did not. The same problem still exists. I need the 'fake view' to make the footer appear properly.

I can give you the credentials for the staging site if you need them to go and remove the fake view and see for yourself. (or maybe you can see it like you did above by just putting the function into footer.php directly).

My footer fails if there is no other view on the page, hence the need for a 'fake view'.