[Closed] Use my location not working in CRED form – only on mobile devices

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Nigel 9 months, 4 weeks ago.

Assigned support staff: Nigel.

Author
Posts
#1259011

I am trying to: Set a location field in CRED form with the user's current location.

Link to a page where the issue can be seen: [site_url]/new-business-submission/

**Note the address field is conditional. In the Contact Details section select the 'We have an address' option and the address field will appear.

I expected to see: When clicking the 'Use my location' link I get prompted to allow the location to be used but it doesn't update the field. Entering the address works fine.

This works fine on a mobile device.

Instead, I got: Doesn't work.

#1259077

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi James

It worked when I tried it just now, see the screenshot.

Browser permissions like this can be tricky because the site only gets to ask once, and if the user denies permission the site doesn't get to ask again, it's down to the user to modify the browser permissions for the site. So if in testing you have ever denied permission, you likely won't see the prompt again, and I suspect that's what's happening if you are not seeing the prompt.

Try in a different browser that you certainly haven't tried with before, or update the settings for your normal browser.

As an aside, you may want to style the "Use my location" link a little more prominently.

#1259151

Hi Nigel,

Thanks for you help with this one.

I have tried four browsers - all with the same result.

I get the 'allow' pop up too and click to allow but the location doesn't show in the map.

I am getting a 'no response' notification in the console. See attached.

Thanks,
Chris

#1259767

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

OK, going past the browser authorisation I'm seeing the same, and I'm actually seeing the same on my local test site.

But a colleague has it working fine on their test site.

I'm still working on this and will update you again.

#1259935

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Chris

Google suffered major outages over the weekend affecting various regions, and it looks like that is affecting this.

When you click the "Use my location" button we (the Maps plugin) just requests the location from the browser, and the browser then attempts to get/provide the coordinates.

I can't get the "Use my location" button to work on any site, and I suspect you would find the same.

My colleague who is able to use the button on his own test site is also able to use it without problem on your site (screenshot).

So, I don't have anything to suggest except to keep trying periodically to see when it comes back.

It looks like this site is in development, but if it is live and has this problem you may want to temporarily hide the Use my location button with CSS.

#1259969

Thanks Nigel.

You're correct, this is in development so not pressing right now.

I'd like to leave this ticket open for a little while as I wait for Google to get it's act together here.

Appreciate your help as always.

#1260735

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

No problem, but let me mark this as awaiting your feedback so that it's not sitting in my queue.

(You'll get a reminder in a week.)

The topic ‘[Closed] Use my location not working in CRED form – only on mobile devices’ is closed to new replies.