Skip Navigation

[Resolved] Update not showing

This thread is resolved. Here is a description of the problem and solution.

Problem: The option to update the Access plugin seems to have disappeared.

Solution: Older "WPML - complementary" accounts included Access. Because this account type is no longer offered Access was missing from the list of available plugins passed in a JSON file in the custom installer. This has now been fixed, but may require you to press the Check for updates button on the installer page.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 17 replies, has 2 voices.

Last updated by idigon 2 years, 6 months ago.

Assigned support staff: Nigel.

Author
Posts
#1236024

I am trying to:
Update Access to latest version

I expected to see:
Option to update through wordpress dashboard

Instead, I got:
No update is showing.
If i go to the list of plugins i see this error: "You must have a valid subscription in order to get upgrades or support for this plugin". But when i go to the Plugins / Commercial tab, it says "Toolset is registered on this site". I have tried unregistering and registering again, but I still cannot see the latest update.

Thanks,

#1236059

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Could you please share your debug info?

hidden link

#1236254

Sure, I just added it. thanks!

#1236310

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

OK, thanks.

Could you please try a couple of things.

First, go to Dashboard > Updates and press the Check Again button to check for plugin updates.

If that doesn't help unblock the situation, can you go to Toolset > Settings and find the "Toolset Debug Information" link at the bottom and follow it.

On the resulting page at the bottom there is a link to the Installer support page, could you please visit that.

Can you show what it displays there?

#1239012

Hi,

first, sorry for the delay in replying.

Going to Dashbord -> Updates > Check again makes no difference.

The installer support page shows:

Installer System Satus -> everything ok (green ticks)
Required Libraries -> everything ok (green ticks)
All Installers Instances -> only the path to the sitepress-multilingual-cms is showing. Should there be a Toolset installer there?

Also, if I go to Plugins -> Add New -> Commercial, WPML is showing a list of all available plugins. But Toolset only shows the message "Toolset is registered on this site. Your Lifetime account gives you updates for life.", but not a list of plugins below.

Thanks,

#1239027

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Thanks for reporting back.

I'm not sure whether it is a problem for your account type or if it is an isolated issue affecting only you (no other reports), but I've passed the details on to the installer team who will investigate.

I'll let you know when I have some feedback to share.

In the meantime are you able to download the latest Access from toolset.com/account/downloads ?

#1239038

Ok thanks!

Yes, I can download Access 2.7.2 manually.

#1239045

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Could I ask you for access to your site?

We want to run a couple of tests re-registering the site with a different account.

I'll mark your next reply as private.

#1239696

Hi,

do you need an admin account to access the site? Isn't there any other way to debug this? (I can try to re-register the site if you send me a test key).

One more thing: I'm only using the Access plugin (not Types). I've never had any issues updating til now.

thanks!

#1240419

Hi,

any news about this?

If I decide to update the plugin manually, what are the recommended steps to update Access?

1. Disable Access plugin
2. Delete Access plugin
3. Install new version of Access
4. Enable Access

I assume no data or settings will be lost, right?

#1240429

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Yes, those are the correct steps, and, correct, you won't lose data or settings doing the above.

I'm still waiting on our systems team to get a trial WPML Complementary account for testing so I don't have any news just yet about the underlying issue, and I'll let you know when I do.

#1247919

Hi,

any news about this. I see you've released a new version of Access but I still don't get the updates through the dashboard.

Thanks,

#1247937

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

There is no progress visible on the internal ticket I escalated so I've asked for an update and will get back to you.

#1251863

Hi! Any progress on this?

Thanks!

#1251901

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

I've asked once again for an update from the relevant team, I still don't have a reply from them.

I've asked my manager to step in and hopefully we can get an answer soon.