Skip Navigation

[Resolved] Update failed. The response is not a correct JSON response.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by yoshihikoH 1 month ago.

Assigned support staff: Waqar.

Author
Posts
#1673327
#1674119
#1674265

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

This error message can be a result of some code conflict from theme or plugins or if there are some security restrictions in place for API requests.

To troubleshoot this, I'll suggest the following steps:

1. Please make sure that WordPress, active theme, and plugins are all updated to the latest versions.

2. It would be interesting to test this with all non-Toolset plugins disabled and a default theme like Twenty Twenty.

If it's fixed, you can start adding the disabled items, one-by-one, to narrow down to a possible conflicting one.

3. In case the issue still persists, I'll need to see how the custom fields and the content template is set up on your website, in the backend.

You're welcome to share temporary admin login details in reply to this message.

Note: Your next reply will be private and please make a complete backup copy, before sharing the access details.

regards,
Waqar

#1677959

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for sharing these details and sorry about the delay in getting back on this.

When I tried to access the admin area, it showed this message instead:

"Forbidden: You don't have permission to access this resource."

It looks like some security plugin or hosting is restricting access to the admin area.

Would it be possible for you to whitelist my IP address "72.255.36.152" so that I can access the admin area?

If that is not possible, you can share a clone/snapshot of your website, so that I can test it on my own server.
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

Note: I've set your next reply as private again.

regards,
Waqar

#1678453

Dear waqar

The ID for accessing the server was incorrect, so I will correct it.
ID:
hiraisophy.jp → hirai@sophy.jp

Best regards

#1683449

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for providing these details and sorry about the delay in the reply.

Since the issue is not reproducible on a new test install, the issue seems to be specific to your website or server.

Can you please provide a clone/snapshot of your website, so that it can be investigated on a different server?
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

This will help in ruling out any custom or third-party code conflict and I've set your next reply as private again.

Meanwhile, you can also turn on WordPress debugging and see if any errors or warnings are logged in the server's error logs and also extend the relaxation in the security restrictions to few more days until this investigation has completed.

regards,
Waqar

#1687271

Dear Waqar

I was able to solve my problem.

1. I changed the theme to Astra.
2. I tried to stop the WAF in the server security settings.

I tried the above two. As a result, the toolset is now working properly.
I am very grateful to you for your support.

Thank you very much.

#1715611

I have a question about a front-end form for editing content.

My actual operation
1. I created a form for editing
2. Created a content template to display the edit form → Inserted "Fields and Text" in the template that displays the custom post.
3. Inserted a link to the content template that displays the form
→ The following message was displayed and the short code could not be inserted.

Create a new content template to include the edit form.
You can start from scratch, or you can copy your template and view and modify the content.
Toolset Edit Link Material • View or Create All Available Content Templates”

I want to solve the above problem. Thank you.

New threads created by Waqar and linked to this one are listed below:

https://toolset.com/forums/topic/split-using-the-front-end-form-for-editing-content/