Skip Navigation

[Resolved] Update 1.9 created layout changes… again

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Brad 5 years, 2 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#312301

The 1.9 update was deja vu all over again. It reminded me of my previous issue at https://toolset.com/forums/topic/types-1-6-update-breaks-layout-that-worked-in-types-1-5-7/.

Having had that previous experience where a Toolset update caused unwanted layout changes to my website, I was able to work around the issue. However, I think you guys probably want to put out a version that does not produce any such unwanted layout changes. So I'm letting you know what my experience was.

My Types shortcodes were working fine without any

output="raw"

. After the 1.9 update I found I needed to add the

output="raw"

to all my Types shortcodes. Also, I had to modify one of my own shortcodes so that it now adds

<br>

tags. See below:

I changed from

$result = implode("\n",$temp);

to

$result = implode("\n<br>",$temp);

After making these changes, my layout is back to what it was before the 1.9 update.

If you plan on tweaking the 1.9 update to go back to the original layout result, please give me a heads up so I can plan to undo the changes I just made.

Thanks.

#312356

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Brad,

Thanks for share the workaround, hope it help other users, and I forward this problem to our developers.

#315973

I am marking this issue as resolved since I resolved it with the workaround that I described.