Skip Navigation

[Resolved] Unable to use File URL as the URL for dynamic data to a button URL

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Christian Cox 5 months, 1 week ago.

Assigned support staff: Christian Cox.

Author
Posts
#1985911

Hello Support.

I have created a custom field of type File
It basically saves a URL in the database to a file. You can actually write https://toolset.com in the url field even though that is not a file that is placed on that url 🙂

And that is ok.

But you are unable to select custom fields of type file as dynamic data sources for the Button URL, even though the data saved in the database is a URL.

Please see this video : hidden link

I am sure you are only allowing me to select the custom fields that are of type URL, and I need to be able to select more fields that actually saves a url in the database.

#1986175

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, let me ask my 2nd tier support team to take a closer look at this. In my local tests, I am able to select from various field types for the Dynamic URL source, including audio, video, and image fields...but not file fields. I am not sure if that is a bug or the expected behavior. It seems that it should be possible to select a file type field, but that does not seem to be the case here. It may be necessary to use a custom CSS workaround. I thought it might be possible to use the Container block's "Container as Link" feature, but I found that it is not possible to select file fields in the dynamic sources for this block either. So instead, you could use the Single Field block to display the file field as a link, and apply custom link styles to make it look like a button.

I will get some feedback from the team and give you an update as soon as I can.

#1987093

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have some feedback from my 2nd tier support team. It turns out this issue was already reported and our developers plan to include the fix in the next round of plugin updates. The fix update is tentatively scheduled around the end of the month, and I'll keep you posted here as I receive more information about that timeline.

#2020687

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, our team is now in the process of pushing out the latest Toolset release. If you have not yet been prompted to update to the latest versions, you may need to go to wp-admin > Plugins > Add New, then click the Commercial tab. In the Toolset Installer panel, click "Check for Updates", and the automatic installer should find the latest versions of Toolset plugins ready to install. The fix for this issue is included in the latest updates. Thanks for your patience while we worked to resolve this issue. Feel free to close here or let me know if the issue is not fully resolved.