Skip Navigation

[Resolved] Unable to get the map to show

This thread is resolved. Here is a description of the problem and solution.

Problem:

The issue here was that the customer had created the map fields on the backend but didn't know how to display his map on the frontend.

Solution: The best way to resolve this is to have a look at our Maps documentation https://toolset.com/documentation/user-guides/display-on-google-maps/#maps-on-frontend

This should be able to guide you through the process as well as introduce to you any features that you are not aware of.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by BarryS9673 3 years, 8 months ago.

Assigned support staff: Shane.

Author
Posts
#613483

Hi,

I have created a Field type for Maps, however I am unable to get it to display on the front end, any advice?
Also I am wanting to add a form to each page, should I start anew topic on how to create forms?

#613509

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Barry,

Thank you for contacting our support forum.

Would you mind providing me with admin access to the website so that I can take a look at this for you ?

The private fields will be enabled for your next response.

Also please send me a link to the page that has the map on the frontend.

Thanks,
Shane

#613774

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Barry,

Thank you , I was able to see the issue at hand.

The best way to resolve this is to have a look at our Maps documentation
https://toolset.com/documentation/user-guides/display-on-google-maps/#maps-on-frontend

This should be able to guide you through the process as well as introduce to you any features that you are not aware of.

Please let me know if this helps.
Thanks,
Shane

#613967

I have done all that and in admin, I see the map, on the front end, I can see the source code but map does not show.

#613971

Hi,

I think I got it, I need to show map and marker...does this look correct or should the map code wrap the marker code?

[wpv-map-render map_id="map-4" map_height="500px"][/wpv-map-render]
[wpv-map-marker map_id="map-4" marker_id="marker-4" marker_title="This is where we will collect you" marker_field="wpcf-coach-holiday-pick-up-point"][/wpv-map-marker]

#614292

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Barry,

This looks correct to me.

Is the map showing up correctly now ?

Please let me know.
Thanks,
Shane

#614302

Yes, I think I have figured it out, did my code that was added to the page look correct to you?

#614305

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Barry,

Yes this code is correct.

Thanks,
Shane

#614316

Thank you Shane