Skip Navigation

[Resolved] Unable to add parent to blog post (default type)

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by MrHinsh 7 years ago.

Assigned support staff: Waqas.

Author
Posts
#253154

I am trying to: Have a relationship between the default post type and a custom post type.

I visited this URL: hidden link

I expected to see: A drop down to select a parent after saving and publishing a post

Instead, I got: "You will be able to add parent posts after saving this post."

Video of Issue: hidden link

#253333

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

types-help-debug.png

I have tried reproducing the same thing on my local host, and looks like all is working fine. I am using the latest release of Types plugin. Can you please provide some debug information, so I can look into further details?

Please see the screen shot attached for a help on how to grab the debug information.

I have enabled the debug information area for your next reply. Please copy the debug information and paste in the available area on this thread.

#253335

Debug was provided with the original thread and I have again added it to the debug box here.

#253366

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for providing the debug information. That looks pretty fine to me.

I have tried created the same bug on my local host but it was all fine. Can you please try creating another CPT (new) and Post relation, and see if it works for you?

However, may I ask you for a temporary access to your website? so I can see in more details. If possible, replicating the same thing over a test site would be fine, since it will not interfere with your production website. On the other hand, please remember to take full backup of your website before providing the access.

I have set your next reply as private, so your information is safe with us. Please enter all sensitive information in the private area provided here.

#253385

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Please notice that "Child" needs relation with a "Parent", which must exist. Provided that, since your standard post is child of your CPT "Engagement", means "Engagement" (is parent) -> of standard post (is child).

For this to work, you need to add some posts under Engagement post type, so your standard posts are able to populate for a choice of parents. I hope this clarifies. See this test post hidden link and is linked with a parent under Engagement CPT.

Again, there's no issue, all you need to have some posts in "Engagement" CPT to work as parent of standard posts.

Please let me know if I can help you with anything related.

#253869

Thanks for the help. The error should be changed to "when you publish the parent" as both the existing post and the parent were saved.