Skip Navigation

[Closed] unable to add custom fields for a type to custom template

The Toolset Community Forum is closed, for technical support questions, please head on to our Toolset Professional Support (for paid clients), with any pre-sale or admin question please contact us here.
This support ticket is created 8 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.
This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 4 replies, has 2 voices.

Last updated by Beda 8 years ago.

Assisted by: Beda.

Author
Posts
#395567

I am trying to: add a custom field onto a template -

I can add any non-custom fields to the template but when I click on any of the custom fields the whole screen goes sort of dark, saying waiting for website then waiting for cache and nothing happens - when I click on the screen it comes back but hasn't inserted the field.

#396060

Do you mean, when you click on the Fields and Views Button, the GUI that should open, actually only darkens the screen a bit, and never really creates a Modal with all available Fields?

This must be a JS conflict with a 3rd party Plugin or outdated Software.

1. Does the issue also persist with a WordPress Default Theme and NO Plugins BUT the Toolset Plugins?

If not, could you then re-enable the Plugins one after the other, and check the issue each time you enable a plugin?
Please report me when the issue comes back
It might also be due to the Theme.
Please do reactivate your Theme only after you are sure the issue isn't coming form a 3rd Party Plugin.

2. Update the Plugins manually

❌ Backup your website and database ❌
• Deactivate/Delete the "Installer" plugin (if you have it)
• Deactivate all Toolset plugins
• Login via FTP to your wp-content/plugins folder
• Delete all Toolset Plugins folders
• Go to https://toolset.com/account/downloads/ and download the latest stable Types Plugin, then extract it.
• Upload the plugin via FTP to the wp-content/plugins folder.
⌥ alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
• Register the Plugin for your site
⌥ you can do that under Dashboard > Types > Settings > Types Tools > Installer
• Download all other needed Plugins
• Activate them in Dashboard > Plugins
This should not generate any problems.

3. If the issue persist, please look at your Browser Console and tell me if you see any JS errors.
hidden link

Thank you

#402541
screen-after-clicking-on-residence-field-address.jpg
screen-before-clicking-on-residence-address.jpg

sorry for the delay in responding but couldn't get back at this stuff till now - the issue is when I try to place one of my custom fields on the form, the screen darkens and goes away and the field doesn't get placed, when I click on the screen everything is back to normal but no field has been placed - if I place any of the normal fields like body or title there is no problem.

I've tried removing all the plugins and starting over and testing one by one but get the same result over and over.

I also tried firefox to look at the console and get the following messages - don't know if they help

"JQMIGRATE: Migrate is installed, version 1.4.0" load-scripts.php:9:541
"Google Maps API warning: NoApiKeys hidden link" util.js:222:11
"JQMIGRATE: Migrate is installed, version 1.4.0" load-scripts.php:9:541
downloadable font: maxp: bad max_zones: 0 (font-family: "ps_g" style:normal weight:normal stretch:normal src index:0) source: hidden link de-43acbb-4b5f58d3:9:349
"<unavailable>" ca:34
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at hidden link?. (Reason: CORS request failed).

Uploaded image before clicking on a field and after so you can see what i'm seeing.

thanks
Eric

#402564

found out the issue was the only plugin I had left in which was google analytics - when I disabled that I no longer had the issue so there seems to be a conflict between that plugin and toolset

#405108

I reopened this Ticket as we must analyse and solve this problem if possible.

1. Please provide a downloadable Link to the Culprit Plugin
(if free)

2. If it's not a free plugin, please provide to me an updated copy of it via Google Drive or DropBox
( I will enable a special form to share the link)

3. Please attach the instructions how I can reproduce this.

The topic ‘[Closed] unable to add custom fields for a type to custom template’ is closed to new replies.