Skip Navigation

[Closed] Types plugin talking too long '100sec' to upload website on admin and on staging

This support ticket is created 8 years, 3 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Ross Fisher 8 years, 3 months ago.

Assisted by: Ross Fisher.

Author
Posts
#363971

I am trying to: website takes too long to upload sometime ends up on 502 error

I visited this URL:

I expected to see:

Instead, I got:

#364041

Thank you for contacting Toolset support, I'd be delighted to assist!

Could you please clarify a bit? Is the plugin itself not uploading due to timeouts or are you experiencing issues uploading files to a CRED form?

#364112

It's only the plugin, it use like 150MB of RAM to generate live website and also admin , every
single time it loads.

#364125

Thank you for contacting Toolset support, I'd be delighted to assist!

I believe I spoke with you at some point in the past about this, if not - someone with a similar issue!

From your debug, you have 256MB of RAM maximum available to PHP which is great! WordPress has a hard cap of 150MB in the wp-admin interface though which is causing this error.

Try adding this to your wp_config.php file:
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

#364149

It made it fast but the page was blank, just to let you know we are using WP-Engine as a host provider ...

Thanks,

#364154

We are getting somewhere!

Can you please switch WP_Debug to on in your wp-config.php file and then reload the white blank page to see the error and paste it here?

#364171

It took 36,000 ms to gave us 502 error

Hope that helps

#364173

Can you please switch WP_Debug to on in your wp-config.php file and then reload the white blank page to see the error and paste it here?

This will output the exact error that is causing the white page and 502 error.

If you don't know how, here is a good how-to:
https://codex.wordpress.org/WP_DEBUG

We want to do this:
define( 'WP_DEBUG', true );
in the wp-config.php file

Then you want to go where you had the white page, now it'll display a specific error. Please post it here to help me troubleshoot.

#364179

I did exact same thing but it's giving me 502 error, so I contacted our host provider and he said server isn't running out of the memory, There is enough memory but the issue is that the way Types is being implemented makes it so that the process takes so long that it is at risk for timing out.

Hope that helps

#364186

I can understand, you have 256MB dedicated to your PHP process. Did you try the

define( 'WP_MAX_MEMORY_LIMIT', '256M' );

in your wp-config file?

How about also adding this other parameter so it reads both:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' ); 

The issue is that while your provider gives you 256MB of RAM for PHP, WordPress itself won't allocate more than 125MB/150MB maximum for frontend/backend - this is a WordPress limit built into WordPress itself.

I look forward to your reply!

#364191

define( 'WP_DEBUG', true );

define( 'WP_MEMORY_LIMIT', '256M' );

I'm using these every time I use debug option IT gives me 502 error and and every time I use WP_MEMORY_LIMIT is gives me nothing just a blank page.

Any suggestion

#364192

To best troubleshoot the problem, I would like to request temporary Administrative access to your WordPress site. Please include the Login URL, Username and Password along with your FTP connection information. Feel free to create a temporary admin user solely for this purpose.

Importantly, please include the FTP information so that I can view the wp-config file.

Your next reply will be private, only you and I will have access to it, I look forward to your reply!

#364388

Hello there!

I'm unable to login:
ERROR: The password you entered for the username types is incorrect.

Could you please check the "types" administrator account and report back?

#364433

I have successfully debugged the site, some notes:

1. Most importantly, contact WP-Engine and ask them to increase your PHP Time Limit to 300 seconds. It's 30 seconds now and with the number of plugins you have installed, you need 300 to prevent timeouts for intensive operations

2. The requested changes:
define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );
were absent from your wp-config file. It may be that wp-engine is overwriting your wp-config file and this needs to be addressed as these two settings must remain in the file

3. You have two conflicting security plugins installed at the same time. Please pick one and disable the other.

For now, the backend is loading for me with the changes from #2. I'm still getting some 502 timeouts though in certain areas, this is due to PHP timing out after 30 seconds, it really needs to be 300.

The topic ‘[Closed] Types plugin talking too long '100sec' to upload website on admin and on staging’ is closed to new replies.