Skip Navigation

[Resolved] Types plugin conflicting with WooCommerce

This support ticket is created 6 years, 11 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 15 replies, has 2 voices.

Last updated by Dylan Harris 6 years, 11 months ago.

Assigned support staff: Beda.

Author
Posts
#306394
Screen Shot 2015-05-27 at 10.39.20 AM.png

The orders and coupons tabs are missing from WooCommerce admin. I contacted WooCommerce and they told me it was a plugin conflict. I narrowed it down to the Types plugin. This is unfortunate because I'm using Views as well. Can you let me know if there's a fix for this? Thanks!

#306407
Tabs.png

Thank you for contacting us here in the Support Forum
and for providing the Debug Informations

I am not able to reproduce this.

As you see in my screenshot, I have Views (+WC Views) + Types and WooCommerce installed as well, but the orders and coupons tabs are not missing.

This seems to be cause by another conflict.

Does the issue also persist with our Default Theme Toolset Bootstrap and NO Plugins BUT the Toolset Plugins + WooCommerce only?

If not, could you then re-enable the Plugins one after the other, and check the issue each time you enable a plugin?
Please report me when the issue comes back
It might also be due to the Theme.
Please do reactivate your Theme only after you are sure the issue isn't coming form a 3rd Party Plugin.

In case the issue then persist, please follow this below instructions:

INSTRUCTIONS:

Backup your website and database
? Deactivate/Delete the "Installer" plugin (if you have it)
? Deactivate all Toolset plugins
? Login via FTP to your wp-content/plugins folder
? Delete all Toolset Plugins folders
? Go to https://toolset.com/account/downloads/ and download the latest stable Types Plugin, then extract it.
? Upload the plugin via FTP to the wp-content/plugins folder.
alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
? Register the Plugins for your site
you can do that under Dashboard > Types > Installer
? Download all other needed Plugins
? Activate them in Dashboard > Plugins
This should not generate any problems.

In case you want to register Toolset Plugins for your site manually please make sure to enter the naked URL of your site in wp-types.com (something like hidden link)

In the extreme case, please try to register with all non-Toolset Plugins deactivated,
and Theme Toolset Bootstrap enabled.

Please don't hesitate to inform me in case the issue persists
and let me know if the above solution works for you, I look forward to your reply!

Thank you

#306503
Screen Shot 2015-05-27 at 3.16.15 PM.png

Ok, so I deactivated all of my plugins except for woocommerce and types. I don't have the Toolset Bootstrap Theme, but the theme I'm using is called Sahifa and it says it's fully compatible with woocommerce. I'll contact them as well. Anyways, orders and coupons are still missing. The site hidden link was already built with Sahifa, so changing the them isn't an option at this point. Your thoughts?

#306667

Thanks for the Details

Can you confirm to have manually re-installed the Plugins as above suggested?

I can not reproduce this on a clean WordPress install with freshly installed Plugins.

I also tried different install sequences, but the mentioned tabs do always appear properly.

If you already followed the suggested manual reinstallation, please could you either provide me access to a Test Site or even better, send me a Duplication of your site?

This way I can troubleshoot it locally and try to spot the issue.

We usually recommend the free Plugin "Duplicator" for this porpoise (to create site's duplications)

If you already know how Duplicator works
(http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

Duplicator Instructions
hidden link
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

IMPORTANT
Remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Please could you provide me the additional Details?

Thank you

#307567

This site is live, so please download the files I sent and work offline. Thank you!

#307826
Bildschirmfoto 2015-06-03 um 11.38.18.png
Bildschirmfoto 2015-06-03 um 11.38.10.png
Bildschirmfoto 2015-06-03 um 11.38.02.png
Bildschirmfoto 2015-06-03 um 11.37.54.png
Bildschirmfoto 2015-06-03 um 11.37.46.png
Bildschirmfoto 2015-06-03 um 11.37.33.png
Bildschirmfoto 2015-06-03 um 11.35.29.png

Thanks for the Details

I am not sure why, but this URL gives a E404:
hidden link 404

I downloaded your packages, installed all Plugins and all your Themes locally and tested it extensively.

I was no table to reproduce this problem.

You can see in my screenshot, the Tabs are correctly available.
Also, all plugins are installed and active, as you can see.

I need to know how to reproduce this issue to solve it.

I can't reproduce this on a fresh WordPress Install, running all your Plugins and Theme.

The issue could rely in configurations, Server Settings, Corrupted Files, there are many variables.

What we can try, is if you could send me a Database Dump made with Adminer Plugin
https://wordpress.org/plugins/adminer/

Perhaps the issue relies in the settings of the DB.

Please can you send me a Database Dump?
(not a BackUp Buddy Snapshot, but a Database Dump Only, in zip or gzip format, or just sql format)

Please could you provide me the additional Infos?

Thank you

#307896
Bildschirmfoto 2015-06-03 um 14.23.33.png

Thanks for the Details

This SQL is corrupted, at least the one I downloaded (the one you submitted above) and installed on the Database for this use.

See the screenshot, it misses any default WordPress table.

I assume this is not the same your end, as otherwise you would not be able to use your site.

Can I ask permission to install Adminer on your Site, and try to export the Database to check if the issue repeats?

Thank you

#307909

Hm...you can go ahead and get what you need from the site. I already have adminer installed.

#308114
Bildschirmfoto 2015-06-04 um 09.28.30.png

I tried to export the Database but I am getting a E404 after the export finishes
(instead of downloading the -zip)

You can see it in the screenshot.

Can you please turn on your WP-Debug mode and see if there are any errors?
https://codex.wordpress.org/WP_DEBUG

Please report me if you see any errors.

The problem is, without a running and working site where I can reproduce this problem, I also can't solve it.

I have another idea which might help us to solve this:

I can request a real online test site for you (this is free, we do that in such cases to better solve issues)
You can then import (duplicate) your site to this new test site, and if you are able to reproduce the issue there, we can go ahead and start solve it.

Would you agree with that?

Please could you provide me the additional Infos?

Thank you

#308153

This is what WP-debug returned:

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/cmbrkich/public_html/castletoysandgames.com/wp-includes/functions.php on line 3508

That's part of the standard wp install. Wonder if I just overwrite the whole wp-includes folder if that might fix it. Your thoughts?

#308164

I don't think it's a good idea to overwrite your WordPress Core Files.
They should if possible not been touched.

The issue is caused by "Theme Logo" Plugin.
The Notice should disappear after you disable it.

So, it seems to me this is not the reason why I can't export your Database, and it isn't also the reason of the missing WooCommerce Tabs.

How do you feel about the dedicated Test Site?

I think it could be the currently the best approach, so to solve this effective and fast as possible.

Please let me know.

#308187

We can try the test site. Let me know what I need to do. Thanks!

#308615

Thank you for agreeing to this.

I am waiting for the confirmation of the site's set up.

As soon I have all details, I will send you the complete login details, and will start to troubleshoot the issue as soon you have been able to reproduce this issue on the test site.

You will need to replicate your exact installation on the (blank) test site.

It is recommended to use Duplicator for this porpoise, or any of your preferred methods.

Important is, to replicate the site with your exact Database and FTP files.

Please expect my informations here in the forum.

Thank you

#309084

I have just sent you a Private Email with some details on how to access the new test site we set up for you.

Please follow those instructions and don't hesitate to ask me her win the forum if any issues or questions come up.

Once you have replicated the issue, please inform me here in the forum as well.

I will then login to the test site and see to solve this problem.

Thank you

#310169

I wanted to update here about the process to follow for uploading the Site's snapshot to the test site we set up for you.

I received feedback from the Server Admin, that you might need to "split" the content you upload.

Please try to upload only the necessary files.

Please try to "cut out" all uploaded Images, as they use huge space on servers.

If you create your snapshot with Duplicator, you can "cut" out entire paths or folders or single files in the snapshot's settings. (such as the "Upload" folder)
hidden link

Try to keep the size as low as possible so the upload won't be "stopped" unexpectedly.

Please don't hesitate to inform me in case the issue persists
and let me know if the above solution works for you, I look forward to your reply!

Thank you