[Closed] Types 1.0 migrartion bug/error

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Mikkel 8 years ago.

Author
Posts
#10074

I'm using Types v.1.0
When I go to Migration ( /wp-admin/admin.php?page=wpcf-migration ) I get the following error on a white screen:

Fatal error: Call to undefined function wpcf_custom_types_default() in /var/www/wpkdev.com/vbf/wp-content/plugins/types/includes/migration.php on line 15

#12671

Dear Mikkel,

I have tried migrating from Advanced Custom Fields to the Types beta plugin and it worked fine.

Can you test the beta plugin?

Regards.
Caridad

#13446

I just tried using Types 1.0.1 and Types 1.0.2-b2

The problem is still the same in both versions.

I get a white screen with this error:

Fatal error: Call to undefined function wpcf_custom_types_default() in /home/user_name/mydomain.com/wp-content/plugins/wp-types/includes/migration.php on line 15

#13448

I have tried to delete the plugins via ftp, and upload fresh version via ftp, to make sure the problem wasn't due to a partial install using the admin panels. It did not solve the problem.

#13571

Hi Mikkel,
this actually can happen if you don't have any custom types defined by Types.
Fix is added for next release.

#13654

ok, but I did try to add a custom type in Types, just to make sure, and that didn't make the error go away. Can you explain how I can do so that I can get the migration assistent to work, by adding a custom post type first, that I can delete afterwards..

#13758

Can you try with BETA released today?
1.0.2-b3

#13798

Beta 3 solved the problem, thanks!

The topic ‘[Closed] Types 1.0 migrartion bug/error’ is closed to new replies.