Skip Navigation

[Resolved] Toolset templates not working

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Shane 2 years, 5 months ago.

Assigned support staff: Shane.

Author
Posts
#1193323

Tell us what you are trying to do? Trying to set up archive and single templates for custom posts using Toolset

Is there any documentation that you are following? Toolset site

Is there a similar example that we can see? Can't get Toolset templates to appear

What is the link to your site? hidden link

#1193384

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Patrick,

Thank you for contacting our support forum.

Are you templates being assigned to the posts ? Or are you creating a custom archive with our plugin.

Could you provide a little more details on this for me.

Thanks,
Shane

#1193946

Hi Shane,
I tried assigning templates for both the single and archive for a custom post type using Toolset, but even when it showed as assigned in the Toolset dashboard, the changes to those templates were not displaying when I navigated to either the archive or the single page for that post type.

I am using the Ocean WP theme, Elementor Pro and Toolset. Both the theme and Elementor Pro have areas where templates can be created. It must be that one or both of those is still controlling the templates.

I followed the steps for Elementor provided on your site and I am able to change templates created that way, however what is possible is quite limited because I am only able to access individual Toolset fields through a cumbersome interface. Is there something I can do so that, when I use Elementor's builder and I add a text block, the Toolset "Fields and Views" button appears in that editor?

If I am using this method to create a single template for a custom post type, and I need to show related posts to that one within the template, how do I proceed? Do create a view for those related posts and then use the Elementor interface to add that view to the template?

It might be helpful to make some diagrams showing how these various steps work.

#1193948

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Screenshot 2019-01-31 at 2.30.09 PM.png

Hi Patrick,

What you can do is to enable the shortcode option in the Toolbar, see screenshot

So the issue is that with the related content you must create the elementor template then you must have a view that is to display the related content.

How are the items related ? Are they in a Parent/Child relationship ?

Please let me know.

Thanks,
Shane

#1193961

The single template is for dental offices and I have a many-to-many relationship with another custom post type, Dentists. I made this template in the ELementor templates area and I have it working.

I still need to display the dentists at a particular location with each single location in the Location Template.

#1193989

I think I figured it out. The filter selection needs to be "Select posts in a Location Dentists relationship that are related to the Post where this View is shown."

#1194451

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Patrick,

Happy to see that you're progressing with this.

Is there anything else you need from me ?

Thanks,
Shane