Skip Navigation

[Resolved] Toolset Maps This page didn't load Google Maps correctly. See the JavaScript con

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by rubenB 4 years, 8 months ago.

Assigned support staff: Minesh.

Author
Posts
#432364
Screen Shot 2016-09-05 at 1.23.15 PM.png
Screen Shot 2016-09-05 at 1.22.47 PM.png

Hi, I'm getting the error on the Google Maps Field (see screenshot)

I've followed the instructions here (see screenshot)

https://toolset.com/documentation/user-guides/display-on-google-maps/?utm_source=toolsetmapsplugin&utm_campaign=toolsetmaps&utm_medium=views-integration-settings-for-api-key&utm_term=our%20documentation#api-key

And added the credentials to my develpment site
testingground.dreamhosters.com

In my Firebug > Console > Errors / Warnings there are no entries.
In Firebug > Console > All I can't see anything calling to Google Maps API.

I don't understand javascript or how to use the Console.

Please give me any tips. Its a non urgent issue if you're busy right now though.

#432570

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Could you please try to create new Google Map API and make sure following APIs are enabled:
- Google Maps Geolocation API
- Google Maps JavaScript API
- Google Places API Web Service

Once all of above APIs enabled, please generate new API key (browser key) and replace it with your old map key at toolset map settings page.

Note:
Please try to register your Google map API key without the domain name and check if that resolves your issue.

#434440

Hi Minesh - you're instructions worked!
perhaps as they are different than the documentation

https://toolset.com/documentation/user-guides/display-on-google-maps/?utm_source=toolsetmapsplugin&utm_campaign=toolsetmaps&utm_medium=views-integration-settings-for-api-key&utm_term=our%20documentation#api-key

which states that you need to enable the "Google Maps Geocoding API"

rather than the Google Maps Geolocation API

a bunch of messing around but thanks for helping get it to work!