Skip Navigation

[Closed] Toolset gallery block does not show on wpml dutch transleted site

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 20 replies, has 2 voices.

Last updated by Nigel 1 month, 2 weeks ago.

Assigned support staff: Nigel.

Author
Posts
#1670575

I have a product database on the main english page and in english the archive and sgl product page show fine
The lately added gallery is showing nice on the english sgl product page (template);
(hidden link)

The gallery is translated properly to the dutch version but does not show;
hidden link

Translation see screenshot

I had the same issue with the product PDF's blocks and much later (weeks) they all of a sudden showed up

Does this relate to toolset (caching?) or is this WPMLrelated?

Anyway how to solve this ?

#1671899

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Firstly, have you intentionally translated the Content Template?

This is disabled by default, and you have to change whether templates can be translated.

You would normally use the same template for different languages. You translate the content, but output it using the same template (which displays the translated content as appropriate).

It would only be if you want to display different things on different language versions of posts (e.g. show information about an event that is only happening one language) that you would ordinarily translate the templates.

So, my advice would be if you don't need to translate the tempaltes, don't.

On my local test site I found that when I did translate a template that had a gallery block in it, it initially worked, but if I made any change at all to the translation (switching from the Visual tab to the Text tab in the editor was enough) then the gallery block would break on the translated version.

#1674313

I am confused now.
In order to view the sgl toolset template in Dutch i need to translate some text blocks (see attachment 1)
To view this translation i need to have all parts translated (see screenshot 2) so i copied all code parts over one on one to the text tab part .

So what is wise to-do to make (in this case) the product gallery visible on the Dutch page (untranslate?)

#1674891

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Tim

Right, if you include static texts in the template (your heading block, rather than a Toolset heading block with dynamic source that gets its text from the post being displayed) then the only way WPML can translate those is if you translate the template itself.

Right now translating a template that includes Toolset blocks doesn't work very well (which is why it is disabled by default). When you include something like a gallery block there is nothing in the markup for the block that you can touch when translating the template. The solution is to hide such blocks from the translation editor entirely, so that they cannot be broken.

Unfortunately, right now the gallery block (and possibly others) are broken just by the simple act of copying the original and saving the translation.

We have a major development cycle nearing completion whose main focus is new workflows for the integration between Toolset and WPML, but it is still a few weeks from going public.

The only workaround I have for you in the meantime is to

- don't translate content templates
- in your singular template where you need to add static texts (such as a heading) do so using the Custom HTML block and wrap your text inside a wpml-string shortcode so that it becomes available for translation in WPML's String Translation, e.g.

<h1>[wpml-string context="custom-text"]My heading[/wpml-string]</h1>

See https://toolset.com/documentation/programmer-reference/views/views-shortcodes/#wpml-string

Keep an eye out for the next major updates in a few weeks (there will be a blog announcement) which will make this redundant.

#1677397

I will make my client clear that the solution will take a few weeks. Think they will be patient with solving the issue on the horizon.
So after the major update all my present toolset (gallery)blocks will be OK for the Dutch translated page to show properly

Thanks for clarifying

#1710881

Hi Nigel,

"Unfortunately, right now the gallery block (and possibly others) are broken just by the simple act of copying the original and saving the translation.
We have a major development cycle nearing completion whose main focus is new workflows for the integration between Toolset and WPML, but it is still a few weeks from going public."

After the latest wpml update the gallery block Is not even showing as a translatable option (see June 20 screenshot) --> so i am even further away from showing the product detail gallery on my Dutch translated page (English main language page is fine)

#1711061

On some products i had to put products images to copy on translation settings.
Changing this solved the showing problem on my dutch translated site
Most other products had already these settings, and they still do not show

When resetting the latter the website was not showing anymore and luckily the site came back after a few minutes

#1711185

I don know what happend with the wpml update but the Dutch archive page does not show products and search labels anymore .
Only the main language (english) shows products and search labels (taxonomies).

I think you guys have a bigger problem with the latest wpml update grrr...

Please assist since my client is not happy, my site is since this update unstable on loading (maybe cache...?)

Problems with toolset and your companies own wpml product got worse... your shift to gutenberg blocks seams a headache for wpml (i even had to switch from views to block because of new functionalities and you guys promised that views would be future proof too. Disappointed so far with at least the wpml integration

#1712371

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

The updates to Views/Blocks to improve the integration with WPML are currently scheduled for release next week, it sounds like the problem that has arisen occurred because of an update to WPML.

I'm sorry to hear it may have introduced problems.

Let me do some more testing this morning with the latest WPML update to see if I can reproduce these problems, otherwise I might need to get a copy of your site. I'll update you.

#1712659

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

I'm having problems reproducing.

Can I get a copy of your site, with details of steps required to demonstrate the issue with the archives and labels?

hidden link

(We haven't published a fix for the issue translating galleries yet, so that is not expected to work.)

#1716915

Hi NIgel,

Do you mean admin access or a real copy?
If you mean a real copy would a full backup (made with WPvivid) do?

Gr,

Peter

#1716919

Now it is not showing the dutch archive page at all anymore??
The dutch translation is 100% translated

I am getting more and more confused

#1723497

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Peter

I'm really sorry, I'm just back from vacations and I see that no-one replied in my absence (one of the team should have been covering me).

Let me set a private reply now and I can go in and create the backup myself.

#1728151

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Tim

I've identified what the problem is with the products not displaying on the Dutch page.

Your View is set to order the results by a custom field (wpcf-product-view-order-number). The way that queries work in WordPress, any post that does not have a value for the custom field will not be included in the results. There is a warning when you choose that option (see screenshot).

So the problem with the Dutch page occurs because your WPML settings for that custom field are "Don't translate", meaning that on the Dutch product posts that custom field has no value (and so ordering by the custom field means all Dutch posts are omitted).

I installed a copy of your site locally as I didn't want to change anything on your live site, and I can confirm that if you change the translation settings for the custom field to "Copy" then the field values are copied across to the Dutch product posts, and they will then be included in the results of the View.

Unfortunately, the field values will only be copied over when saving posts (or updating translations).

All of the product posts need to be re-saved.

Fortunately, you only have 30 product posts, and you can use WordPress's built-in bulk edit from the admin page that lists the products, make no changes, and save.

Those saved products will then appear in the archive.

While I had a copy of your site installed, I added the current beta versions of WPML and Toolset and then tested translating a page with a Gallery block, and I found that it worked, without breaking as per your original report.

#1730361

Hi NIgel,

To get it all clear i do the next things to solve my issue.

I edit each product to see that my custom field product order is set to copy in the translation settings at the end of each product page.
After that in all product per product i click on the Dutch translation pensil en resave this by save and close

I did with some products 9most of them are already on copy and the custom field settings of the order.. was already set to copy them.

All that is checked and resaved as above does not change anything in the DUTCH view. It did for 1 or 2 products beforte but then the whole DUTCH view broke ??

Can you give it a try on my live website with product cc240T, Scigrip SG300 and see if you can get them visable (and my settings are done correctly)

Admin Login should still work

The topic ‘[Closed] Toolset gallery block does not show on wpml dutch transleted site’ is closed to new replies.