Skip Navigation

[Closed] Toolset Forms Create/Edit Post type doesn't work in Safari 12.1.2

This support ticket is created 4 years, 2 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+01:00)


This topic contains 1 reply, has 2 voices.

Last updated by Nigel 4 years, 2 months ago.

Assisted by: Nigel.


I am trying to: Use Toolset Forms to Create/Edit a Post type. The post type exists. I get this error in Safari 12.1.2 (Mac OSX 10.14.6): Please, select a post type before creating a Form. The Post type fields don't display. The process works in Chrome, however, on the same Mac.

Link to a page where the issue can be seen: unfortunately, this site is behind a firewall. I can move it into production if you'd like to see it there, but i've verified the bug several times now.



Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi David

I tried this on my local site with Safari and it worked okay.

When you create a new form the form editor instructs you to select a post type. If you do so with the select dropdown at the top of the form then the form editor updates with the normal UI for designing the form.

I'm using Safari 13.1, though.

It's probably easier for you to upgrade to the current Safari version than it is for me to downgrade.

Could you try with the latest Safari version?

If you still see problems please check the browser console for errors and warnings. Also check the Network tab. When you switch post type with the select dropdown an ajax request is made, the results of which are used to update the form editor. See if the request completes successfully or if there is some error.

The topic ‘[Closed] Toolset Forms Create/Edit Post type doesn't work in Safari 12.1.2’ is closed to new replies.