Skip Navigation

[Resolved] Toolset Access & JWT Plugin

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 5.24 hours from now. Thank you for your understanding.

Author
Posts
#1646077

I am trying to:
All is explained at
https://toolset.com/forums/topic/error-404-toolset-access-logged-in/#post-1638025
Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

#1646095

I want to change to Wakar or Nigel

#1647313

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi

Thank you for contacting us and I'd be happy to assist.

As Christian explained in the other thread, Toolset plugins are designed to run on websites directly and we don't officially support integration or compatibility with mobile app platforms like "AppPresser".

Still based on your report, I can escalate this issue to the concerned team to see if something can be done to investigate this potential compatibility issue at the developer's level.

For this escalation, I'll need the contact information of the point person at "AppPresser" who is leading this testing/investigation.

You're welcome to request this information from the "AppPresser" and share it here.

regards,
Waqar

#1647319

Yes please we need intervention from Toolset, for both of you say it's your responsibility to solve it, & I am inbetween the issue persists causing me postpone launching the Application
support@apppresser.com
Damien is the one who holds the issue.
Thanks.

#1649043

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Screenshot-3.png
Screenshot-2.png
Screenshot-1.png

Thank you for sharing this contact information.

During testing the App on my Samsung A7 (SM-A720F - Android version 8.0.0), I was able to access several pages after logging in using the provided credentials.
( please refer to the attached screenshots )

Can you please share more specific information about the pages which are showing error 404?

Before it can be escalated to the developers, I'll need to know exactly which pages are failing.

#1649117
Screenshot_20200603-154254.png

Yes I was deactivating the JWT plugin to test, so kindly retest more specifically on the side menu SN section.
Thanks

#1651751

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting, while I performed some further investigation.

During testing, I noticed that one thing that is common between the pages that are showing 404 not found from inside the App is that they all have the Arabic characters in their URL/slug.

If it was related to Access post group permissions, the page like "Home SN" would also show 404 as it has the same "New Member" post group assigned to it.

I'd like to reiterate that since those pages are loading fine from the browser directly, the focus of the investigation should be on how AppPresser communicates with the server and loads them and not on Toolset Access plugin's functionality.
( since it is doing what it is supposed to do in the environment that it is designed to work, which the web browsers )

As a quick test, you can remove the Arabic characters from the slug of the page like "آخر تحديثات Recent Updates SN" and then see if it gets loaded properly inside the App. If that fixes the issue you can discuss this limitation with the AppPresser team.

#1651823

Dear I understood what you meant, no the Home SN page isn’t opening the targeted page lifechangingtruth.org/sn/ but opens the main page of the site seems it’s redirected.
So the Arabic characters aren’t the issue...
Kindly see the video in this link:
hidden link

Kindly notice:
The Toolset Access when it’s Deactivated the App works fine...all the pages that have permission groups causes error....even the public pages sometimes show error. But the sure are the permission pages.
I think you need to check the JWT Plugin how it works & modify the Toolset Access to let the pages appear without problems.

AppPresser’s Explanation:
From what we can tell at the moment is that Toolset Access does not like the JWT Authentication plugin.

Quoting:
Update to a better login system (JWT)
Using JSON Web Tokens not only makes your app more secure, but it also allows us to build API based membership features. In the future you will be able to grab WordPress content from the WP-API and check if the user is permitted to see it first. This is huge!

Please answer quicker than that.
Thanks

#1653889

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these details.

I've shared this report with the concerned team to see if this can be investigated as a compatibility issue and will keep you updated through this ticket.

Meanwhile, a possible workaround that you can try is to use "toolset_access" shortcode in place of Access post groups to protect the content based on user roles, and see if that works.
( ref: https://toolset.com/documentation/user-guides/access-control/access-control-texts-inside-page-content/ )

#1654591

I have turned off Tool Access & used another plugin for access control
Thanks a lot.