Skip Navigation

[Closed] The view doesn't work when there's items in the specific category

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by Luo Yang 1 year, 1 month ago.

Assigned support staff: Luo Yang.

Author
Posts
#1726341
Capture d’écran, le 2020-08-03 à 19.21.43.png
Capture d’écran, le 2020-08-03 à 19.21.57.png
Capture d’écran, le 2020-08-03 à 19.22.15.png
Capture d’écran, le 2020-08-03 à 19.22.32.png

Hi,

I have difficulty to show a view with WooCommerce product categories. I'm using Elementor to show the view and using the shortcode OR using the Toolset View widget and I'm getting the same error. Every category page where there is product to show, I'm getting a blank page. Any category page with no product to show, the page seems to work fine by showing "No item found". I have setup the view with the filter : Taxonomy is set by the page where this View is inserted.

I really don't know what to do to get this fixed. Can you help me?

Thank you!

#1726645

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

It seems to be a known issue, the content template of taxonomy view won't work in archive page, see our erratum:
https://toolset.com/errata/content-template-is-not-rendered-if-added-outside-the-archive-loop-of-a-view/

Please try the workaround in above erratum:

The recommended workaround is to not use Content Templates to group fields in a Taxonomy View.

#1731905

Hi! Thank you for your answer. But this page just tell me to not doing what I'm doing... but doesn't give a real solution or a different way to get what I'm looking for.

My Product Archive template page is created with Elementor (and it needs to be like this for other reasons). In this page, I want the product to be showed for that specific product category. Can I create a view where I can use the Toolset view widget to have the results published on the page?

Thank you for your help!

#1732663

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The workaround is simple, you can edit the view you mentioned above, in view's loop:
1) Remove the content template shortcode [wpv-post-body ... ]
2) Copy/paste codes of content template into view's loop, display them directly without content template.

If you need assistance for it, please provide a test site with the same problem, also point out the problem page URL and view URL, I can setup a demo in it.

#1735389
view.png
Capture d’écran, le 2020-08-11 à 21.40.53.png
Capture d’écran, le 2020-08-11 à 21.39.41.png
Capture d’écran, le 2020-08-11 à 21.38.45.png

Hi,

Thanks for your answer. Actually, I'm only using a view without any content template. There is only a view that I'm using the shortcode into Elementor to show the results. In Elementor Edit Mode, I can see the view without issue, but once online on any product archives, I'm getting a white page instead. There is a conflict somewhere and I can't tell where it is. Because I should at least see the Archive title that is setup in Elementor, not in Toolset.

This website is actually a staging website. I can give you the access so you can try to fix the issue if you can.

Example of a page with the issue : hidden link

Thank you for your help!

#1735423

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

As I mentioned above, you can try these: edit the view of your screenshot:
https://toolset.com/wp-content/uploads/2020/08/1735389-view_2.png

in section "Loop Editor", replace the content template shortcode [wpv-post-body ...] with those codes of content template content:

<div class="archive-product">
...
</div>

And test again.

Private message box enabled again, in case you need more assistance for it.

#1736799

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I can login your website and have found two problems:
1) The taxonomy view "Product category view"
hidden link
it is querying "Product categories" taxonomy term, but you are displaying product post information in view's loop, this will conduct unexpected result.

2) In the problem page:
hidden link
I can not find where you display the taxonomy view shortcode, so I have changed the Elementor template:
hidden link

Display below three items:
1) Current archive page title:
https://toolset.com/documentation/programmer-reference/views/views-shortcodes/#wpv-archive-title

2) Child "Product category" terms:
hidden link

3) All "Product" posts assigned with current term archive page:
hidden link

Test it in front-end:
hidden link
It works fine, and it is only a demo for your reference.

#1736819
Capture d’écran, le 2020-08-12 à 22.30.17.png
Capture d’écran, le 2020-08-12 à 22.24.04.png

Hi,

Thank you for your help. We are going in the good direction but it's not exactly like it supposed to work. You have put all the sections and the Product Category View in the website heading (Elementor). So that means that what you added is showed in every single pages of the website, including pages without products.

I'm using a Elementor Template for All Category Archive and that's where we should put what you added in the heading. But for some reason, this Product Archive Template is not loading properly. It seems that something else is showed instead but I don't know what.

Attached you can see the template that should be loaded on every Product Archive Pages and What we should see there. But instead, it's a blank page.

In that case, maybe it's an issue with Elementor and I should contact them instead to help me solve the issue?

Thank you!

#1736901

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Since you are going to style and format the Product Category archive pages using Toolset plugins, I suggest you try these:
1) Disable Elementor page builder for Product Category archive pages, so your website can display default results from WordPress core, and your website isn't in English, it is hard to find the related Elementor settings, you can check it with Elementor support for it.

2) Follow our document to customize the Product Category archive pages with Toolset Blocks plugin:
https://toolset.com/course-lesson/creating-a-custom-archive-page/
And display what you want

#1743725
index.png

Hi Luo,

Thank you for your patience. So I got the product archive working by making the full archive page loaded with Toolset instead of having a Toolset View inside an Elementor template page.

But I'm facing another issue. My burger menu at the top left doesn't open (it's an Elementor popup) when we are on a Toolset template page. So now that my Archive and Single product pages are loaded with Toolset template, this popup menu doesn't load on those pages. But it is working on the home page and all other static pages not attached to a Toolset Template.

I contacted Elementor to see how to fix the issue. They told me : "you will need to contact the Toolset developers to implement their pages in the Display Conditions from the popup."

You can see in the printscreen where Toolset template pages should be added. For now, I can set Elementor Template to be loaded on WooCommerce, Archive and single. But a toolset template page should be added to that dropdown menu to load Elementor popup on all Toolset Pages. Is that something possible?

I really like my popup menu and my client love it and I want it to work on every page of the website. If you have any solution for that, I would be more than happy.

Thank you very much!

#1743787

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

JS-ERROR1.JPG

I assume we are talking about the popup menu in top left of your website page:
hidden link

It can not open.

If it is, this should be a JS/Compatibility issue, I see below JS error in above page:

Uncaught SyntaxError: Identifier 'wpvViewHead' has already been declared
hidden link

See my screenshot JS-error1.JPG

It might conduct the problem you mentioned above, please try to fix the JS errors first:
Deactivate all other plugins, and switch to wordpress default theme 2020, and test again

If the problem is fixed, then activate other plugins/theme one by one, try to locate the problem plugin.

#1744791

Hi,

One of the issue was caused by the plugin WP Rocket. I just had to uncheck the option : Combine JavaScript files. I also checked the option : Remove jQuery Migrate.

So for now, it seems to work on the Product Archive pages but I still have an issue on the Product Single Pages. Here is an example of a product page. It only show the product title for now for testing. But you can see that the menu doesn't load :

hidden link

I have desabled all plugins except Elementor and Toolset and the menu still doesn't want to load.

Any idea what the problem can be this time?

Thank you very much!

#1744851

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I need your permission to deactivate plugins/theme in your website, please backup your website first.

#1744867

Hi, I just did a backup with Duplicator. You all good to go! Thank you again!

#1745131

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

It seems to be a compatibility issue, I did not see any JS errors in your website, and I have tried these in your website:
Edit product post:
hidden link
in section "Content Template", choose option "None"
Save and test again. then the popup menu works again.
hidden link

Since you are using 40+ plugins in your website, it is hard to locate the problem.
According to our support policy, for such kind of compatibility issue, we need to provide steps to duplicate the problem, do you have any clue to reproduce the problem in fresh WP installation? If it needs other plugins/theme, please provide downloadable URL for those plugins/theme.

The topic ‘[Closed] The view doesn't work when there's items in the specific category’ is closed to new replies.