Skip Navigation

[Resolved] Text not showing properly in editor

This support ticket is created 5 years, 3 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 2 replies, has 2 voices.

Last updated by leonardC 5 years, 3 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#557345
editor.jpg

I am trying to: Edit my view

Link to a page where the issue can be seen:

I expected to see: All the text in the code

Instead, I got: Left part of text is hidden behind line numbers

#557434

That's unusual - can you tell me:
1. Are any JavaScript errors displayed in the console when you load this page?
2. Is this behavior seen in all Loop Output editors, or only this particular one?
3. If all Loop Output editors have the same issue, please skip to #6.
4. If only this particular one, cut + paste the existing Loop Output code into a text editor temporarily as a backup, replace it with the minimum Loop Output structure and some lorem ipsum text, then save and refresh the page.

[wpv-layout-start]
	[wpv-items-found]
        <!-- wpv-loop-start -->
	<ul class="wpv-loop js-wpv-loop">
		<wpv-loop>
			<li>
				Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque in ornare turpis, at pellentesque elit. Cras semper odio eu tellus luctus tristique. Aliquam suscipit ullamcorper ipsum quis fermentum. Donec quis metus vel neque tincidunt interdum. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Praesent pretium a libero eu tristique. Nam eleifend viverra maximus. Etiam interdum vulputate mi, id tempor nibh. Cras at lectus convallis, feugiat nulla ut, aliquet felis.
			</li>
		</wpv-loop>
	</ul>
	<!-- wpv-loop-end -->
        [/wpv-items-found]
	[wpv-no-items-found]
		<strong>[wpml-string context="wpv-views"]No items found[/wpml-string]</strong>
	[/wpv-no-items-found]
[wpv-layout-end]

5. If formatting is still off, create a new View and paste in the code you cut from the other editor. Save and refresh the editor page. Check the code formatting in this new View, and if it's not fixed, try to narrow down the problematic code by deleting blocks of code, then saving and refreshing the page systematically. If you're unable to isolate a specific part of the code that's causing the conflict, please paste the entire original Loop Output contents into a text document I can download somewhere. I'll take a look.
6. Temporarily disable all non-Toolset plugins and activate a default theme like Twenty Seventeen. Is the problem resolved? If so, reactivate your theme and plugins one by one until the conflict is revealed.

#557537

Hi Christian

It seems like it was caused by a plugin. Luckily not a very useful one anyways.

Thanks
Leonard