[Resolved] Paragraph inside a Toolset Container Block loses styling on the front end

This thread is resolved. Here is a description of the problem and solution.

Problem: When we apply styles (text colour) to a Paragraph inside a Toolset Blocks Container Block, the Paragraph loses the style set when seen on the front end.

We use the Astra theme and disabling it, solved the issue.

Solution: This is resolved in any current version of Toolset and Astra. If you see similar issues please make sure your software is updated, and if then the issue still persists, please report it to us.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by katjaL 1 month, 3 weeks ago.

Assigned support staff: Beda.

Author
Posts
#1451599

Some styling of paragraph block doesn't apply when inside Toolset container block. Font size seems to apply, but color is lost.
One wonderful thing of the toolset + blocks content templating is the ease. We lose a bit of this if text styling has to be done with css. But perhaps this is only me? (= some plugin conflict)

#1452763

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

There were and are some issues related to that, one is solved here https://toolset.com/errata/styling-not-applied-on-frontend/

However, since you are not using Blocks, that is likely not the issue.
This much more sounds like it
https://toolset.com/forums/topic/container-background-color-not-appearing-in-page-body-using-generatepress

I can however not replicate any issue where the paragraph colours are lost if inside a Toolset Container block.
Can you outline the steps you take so I can try again?

Or, can you try if you can replicate this without any other plugin/theme twenty-twenty to be sure it's not a conflict?

#1452775

Thank you Beda. I have Astra theme and this issue is in content template which I have created with blocks (not classic editor).

In my setup this produces the issue:
- I create Toolset Container
- inside container I create paragraph block
- I assign text color to the paragraph, but it doesn't appear in frontend. The background color does BTW.

#1452781

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

That is not happening on my local install, using the precise same steps.

But as soon as Astra is used, I can see the problem
I am 99% sure it is the same issue as https://toolset.com/forums/topic/container-background-color-not-appearing-in-page-body-using-generatepress, just not limited to a, but many themes.

I'll let you know next week how precisely this can be resolved for good.

#1477817

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

I have no solution for this yet, I will, however, keep you up to date about the progress.
I apologise that this is not yet fixed.

#1488443

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Since the latest updates both of Astra and Toolset, I was not able to see this issue anymore.

It seems fixed, can you confirm this?

#1491533

Yes, you are right! My issue is resolved now. Thank you!