Skip Navigation

[Resolved] Templates using the WPBakery Page Builder – problems

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by Shane 3 years, 9 months ago.

Assigned support staff: Shane.

Author
Posts
#599783

I am trying to:

I use the new integration between Toolset and Visual Composer: https://toolset.com/2017/12/toolset-is-proud-to-announce-that-wpbakery-page-builder-formerly-visual-composer-is-now-custom-types-ready. I created a template, as in the instructions.

I noticed a few problems:

1) I can not use the Toolset values inside the charts VC.
2) If you use quotation marks, for example:
wpv-post-id id="65"
it does not work correctly. It is necessary to use such:
wpv-post-id id=65

#600004

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Oleg,

Thank you for contacting our support forum.

VC charts is this a module of Visual Composter ? If so then it could be that the VC element does not accept shortcodes as data providers.

Secondly what happens if you try using single quotes instead of no quotes? Also under what context are you using the wpv-post-id shortcode.

Please let me know.
Thanks,
Shane

#600503

Hi Shane,

1) "VC charts is this a module of Visual Composter ? If so then it could be that the VC element does not accept shortcodes as data providers."

This page: https://toolset.com/2017/12/toolset-is-proud-to-announce-that-wpbakery-page-builder-formerly-visual-composer-is-now-custom-types-ready/ says: "Use Toolset shortcodes and custom fields in any Elements of the Page Builder (including button and URLs)". Are the VC charts not supported?

2) "Secondly what happens if you try using single quotes instead of no quotes?"

I use a shortcode that is generated automatically. Can you test it and configure this to make it work correctly?

#600555

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Oleg,

Would you mind providing me with admin access to the website so that I can check on these issues for you ?

The private fields will be enabled for your next response.

Thanks,
Shane

#600565

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Oleg,

Thank you for the credentials.

So i've tested this and its not actually a bug its just that the shortcodes are not accepted or rather processed under this context.

This field only accepts the actual static numeric values.

Also the shortcodes seems to work perfectly fine with the double quotes as tested here hidden link

Thanks,
Shane