Skip Navigation

[Resolved] Taxonomy term fields group not saved

This thread is resolved. Here is a description of the problem and solution.

Problem:
In the Taxonomy Edit Screens I can not add Taxonomies and also do not see the Term Fields.
What can I do?

Solution:
Make sure all Toolset Plugins are up to date
Make sure Wordpress is up to date
Make sure this happens as well with Toolset Plugins only and a native WordPress theme like Twenty Sixten
If then the issue still happens, open a Support Ticket.

This support ticket is created 8 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 9 replies, has 2 voices.

Last updated by ivanC-2 8 years, 1 month ago.

Assisted by: Beda.

Author
Posts
#394386
Selection_026.png
Selection_027.png

I have just upgraded to the latest Types (2.01), views and Cred a week or so ago.
I created a new taxonomy and created a new Term fields group for the taxonomy. I noticed the following problems:
(1) saving the term fields group name was successful. Adding a WYSIWYG field was successful. Adding a numeric field was successful. But after the save, the Term Fields summary shows no new term fields group, but indicates several (4) items (see screen shot) which are probably the fields I created and deleted while debugging the problem.
(2) If I create a term item using a CPT associated with the taxonomy, the left hand side of the add new term displays disappears. The screen options bar stops dropping down (see screen shot). If I delete the one and only term I just created, the display works again. The screen option now also drops down, and it shows the term fields which I cannot see in the Term fields summary.

I never used tax term fields prior to the upgrade so not sure if it is the upgrade which caused it to fail or some mistakes I made.

#394589

I can use Custom Taxonomies, with Custom taxonomy Fields, and also add new Terms when this all is created with Types.

It must be a conflict with a outdated Software or a 3rd Party Software.

1. Does the issue also persist with a WordPress Default Theme and NO Plugins BUT the Toolset Plugins?

If not, could you then re-enable the Plugins one after the other, and check the issue each time you enable a plugin?
Please report me when the issue comes back
It might also be due to the Theme.
Please do reactivate your Theme only after you are sure the issue isn't coming form a 3rd Party Plugin.

2. Please could you also try to update this additional Software?:
- WordPress

❌ Be sure to backup your database first before you proceed! ❌
⌥ You can use a plugin for this if you like.
I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Please don't hesitate to inform me in case the issue persists

Thank you for your patience.

#394747

I have tried disabling all but the Toolset related plugins and switched to both a default theme and the Toolset Starter theme, and the problem persists.

I have even gone back to an earlier version (1.9.1) of Toolset with a default theme and Toolset only plugins and the problem is still there.

If you need access to the backend, the login info is in the following thread which your co-worker is looking into Cred notification emails not working after upgrading to version 2.

https://toolset.com/forums/topic/cred-email-notification-stops-working-after-upgrade/

#394913

If I login to that site to try to fix the Issue, I will disable all Plugins that are not Toolset related, and then I will enable a native WordPress theme

If I can not fix it by this steps, I will require a Site's Snapshot, as then the issue is on the server.

This is not a problem generic to Types.

It works fine on many installs and I never saw that issue, so it must either be a compatibility or a Server restriction.

If you want, you can go straight ahead and send me the Site's Snapshot.

We usually recommend the free Plugin "Duplicator" for this porpoise.

If you already know how Duplicator works
(http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions
hidden link
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Thank you

#395276

Well, I downloaded the Site's Snapshot, deployed it and then:

1. Deactivated All Plugins but Toolset
2. Activated a WordPress Native Theme (and updated it)
3. Updated WordPress
4. Re-activated all Plugins
5. Re-activated the Custom theme you where using

To me, the Taxonomies Edit Screens (where you add new Terms) is working properly.

Thank you

#397007

This is frustrating. I tried the same procedures you described on a new WordPress instance. Even with only Types and Views activated and a native theme (2015), I cannot see the term fields group I defined. Do you have any suggestion?

#397138

Then it must be a server interaction that makes this breaking.

I can guarantee you on all sites I know and support here in the forum, Taxonomies can be properly added, deleted and edited.

I can offer you a online test Server, where you could replicate the Website and then we can see if it will work the same way as on my Local host.

I can also login to your Site and see if I can perform the steps there, but as you mention it did not help, so it must be a server issue, there is no other chance for a difference if you followed all steps.

Please let me know if you owed like a online test server (free of charge) and then I would forward you the details.

#397350

I have done the following since your response: in order to eliminate server configurations, I set up a clean WordPress with the latest version and installed Types and Views. I checked that taxonomy fields group is working fine. I then exported all Types and Views data using the Export/Import functions in Toolset and imported them into the vanilla WordPress installation. I can also verify that the taxonomy fields group functions also works with the new installation.

That leads me to suspect it is probably the some internal data in the database which might have been corrupted during various version upgrades.

Is there a way I (or you by logging in) can wipe the Types related database entries clean and use the Export/Import functions to re-build the entries?

#397537

Types does not create any Custom Database Tables, everything is stored the WordPress way.

So that means, to delete contents, you can delete them in the Admin area.
To reset Settings, or change, this can be done in the related Types Admin Screens

If you want to remove all related Types Data, you can as well create a new Install / database, as this would be the clean way to do it.

Types does not store any Custom Tables which you can remove.

Do you have many existing contents on that Site?
Would it be reasonable to export the Posts with the native WordPress export function and re-import them on a new Install?

I can login to see if I can perform the steps suggested - but those are the only I can do, as there are no Database tables to remove.

I can also remove and re-install the Types Plugin or re-install the WordPress, but this are all things that you mentioned you did already

Please let me know how you want to proceed.

This issue is most probably not due to Types but a conflict or a corrupted Database / faulty Update of WordPress
Have you tried to re-install WordPress under Dashboard > Updates?

Thank you

#397754

I updated WordPress to the latest version and that fixed the problem! Thanks very much for your help.

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.