Skip Navigation

[Resolved] Split: Non Toolset relationship – access changes not saved

This thread is resolved. Here is a description of the problem and solution.

Problem: Split: Non Toolset relationship - access changes not saved on form's tab of access

Solution: Please increase value of php.ini setting for "max_input_vars" to 3000 or 5000 and try to resolve your issue.

You can find the proposed solution in this case with the following reply: => https://toolset.com/forums/topic/split-non-toolset-relationship-access-changes-not-saved/#post-1365455

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 6.46 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by geoffD 1 year, 5 months ago.

Assigned support staff: Minesh.

Author
Posts
#1365387

Hi Minesh...

Ok I have been doing some work on this and have found some solutions..so lets start again from the beginning!

I have 3 problems:
1. When I'm in Access Control to set permissions for my various user roles for the various forms it will not save my changes.

2. I have a form with 3 fields - (first-name, surname and full-name) - When submitting the form I need for the full-name field to be automatically filled and saved with the first name and surname merged with a space between
e.g.
first-name: George
surname: Dawson
full-name: George Dawson

3. I have a CPT 'PERSON' that the user creates but can only create one of so - $person[0] I also have a CPT 'PARTNER PAGE' that again the user can only create one of so $partner_page[0]... When I go to the create 'PARTNER PAGE' or the edit 'PARTNER PAGE' I want the fields:
first name
surname
Automatically filled with the first name and surname fields from the CPT PERSON ($person[0])
I need to create some hook that retrieves the PERSON information whenever the create PARTNER PAGE or edit PARTNER page is called

I shall look forward to your response

Best regards
Geoff

#1365389

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

I will handle the following issue with ticket split ticket.

1. When I'm in Access Control to set permissions for my various user roles for the various forms it will not save my changes.
==> Can you plesse share access details so I can loot at the issue. Can you please mention with what post type or form you have an issue with?

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1365455

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I checked on your install and I see that you have around 80-90 Toolset post forms and around 10 custom roles setup on your site.

Could you please increase value of <strorng> php.ini </strog> setting for "max_input_vars" to 3000 or 5000 and try to resolve your issue.

Please check the following Doc:
=> http://stackoverflow.com/questions/10303714/php-max-input-vars
-- Please contact your server admin to update the above setting if you do not know how to do it.

#1365605

Hi Minesh

Ok ...I have created a php.ini file within my wp-admin folder and in the file I have written the code:

max_input_vars = 5000

I have tried to save the access changes but they still don't work...am I doing something wrong?

Best regards

Geoff

#1366001

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

When I checked the phpinfo() I can still see that the max_input_vars ar still set to 1000.

can you please check with your hosting authority and ask them to update this max_input_vars PHP INI variable.

#1366161

Hi Minesh...You have been a superstar as always! My issue is resolved now. Thank you!