Skip Navigation

[Resolved] sometime desktop size view doesn’t work

This thread is resolved. Here is a description of the problem and solution.

Problem: The user is building Blocks to be used by his users in the block editor. He expected to have a "max-width" when we create blocks with the Desktop view.

Solution: We removed the max-width for Desktop, as long as the Toolset Editor Max Width option is active. Can you check if it's active on the sites, which are not working as expected? It should be off (see screenshot) and then your max-width for Desktop should be applied again. Toolset Editor max-width option active

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by nicholasM 1 year, 1 month ago.

Assigned support staff: Jamal.

Author
Posts
#1671497
desktop working.png
desktop-size-broken..png

Now I haven't tested this to death yet so I'm not 100% what is causing this, however I do have 2 sites that I just setup using Blocks 1.2.1 and then I have two that originally had verison 1.2 and have been updated to 1.2.1 , the new ones work as expected, and the updated ones have this issue and had it before the update also so maybe that is what is causing this.

when on Desktop mode I'm not seeing the inline style of 1260px on the block-editor-writing-flow , I need to have consistence here to style my editor backend to make sense for my users. I've included the debug info from one of the sites NOT showing the desktop width. I should not, tablet and phone buttons work as expected it just doesn't work on the desktop button, perhaps there is a setting I am missing somewhere?

#1672217

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

I am not sure to understand very well what do you mean? Maybe this is a usability issue that we should fix, but let me first ask what effects has this issue on your work? Does it generate something odd on the frontend? Or is it only related to editing in the block editor?

If you create a new page/content template in the block editor, does this issue appear? Or is it only for old content?

Can you allow me temporary access to check this closely? Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

#1672325

- it does not affect the frontend.

- When you say you don't understand are my photos not VERY clear?? pressing the desktop button on some installs is NOT adding the inline width like it is supposed to.

- This issue stays in place forever on the sites it affects there is no way to get that button to do anything. If you are on tablet and click the desktop button it clears the inline sizing from block-editor-writing-flow however it does NOT add the 1260px... EVER.

- I don't have the site on a non local server yet. for a workaround I just added a max-width to the block-editor-writing-flow in my CSS and only allow the editor to get that big as I think it looks cleaner for the backend anyway however this is a bug that should be reported

#1672349

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you for your feedback.

Unfortunately, the screenshots were not clear enough, they are partials and I can't know the context, is it a content template? an archive template? A custom post type? A page?

I tried with a page in my local installation, the 1260px was not added for me either, check this screencast hidden link

Can you try again without Toolset Plugins? Is there a difference in whether Toolset Blocks/Views is activated or not?

I am sure you will agree, that if I don't understand the issue from your perspective, and if I am unable to reproduce it, I remain helpless.

#1672471

Well first of all we need to agree that those responsive buttons are part of toolset!! Secondly I believe you are also seeing the bug, I have a colored bg on my editor to make this easier for you to see than in your example. please see my video it has audio.

hidden link

#1673251

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you for the video, and my apologies for my quick reply.

Please let me some time to discuss this internally with the involved teams and get back to you.

#1673889

Christian
Supporter
editor-max-widht-option-off.png

Hey Nicolas,

I'm Christian, a developer of Toolset Blocks.

We removed the max-width for Desktop, as long as the Toolset Editor Max Width option is active. Can you check if it's active on the sites, which are not working as expected? It should be off (see screenshot) and then your max width for Desktop should be applied again.

We change that because otherwise people found it distracting that their editor max width setting was not applied (as it was overwritten by the Desktop max-width). With your ticket I also found out that with the current WP version the width of the Editor Max Width option is not applied at all.

As far as we know also GB is planning some kind of these controls and we would really appreciate that, because currently it's one of the things, which needs adjustments with nearly every WP update. Still both tools are on our list for improvements as it probably takes some time when it becomes a native GB feature.

I hope turning the editor max width option off helps you for now.

Let me know and have a great day!
Christian

#1673933

Ahh great thanks, that makes sense I figured there needed to be a setting as both site environments were the same and working differently.