Skip Navigation

[Resolved] Site went down after updating to View 3.3

This support ticket is created 2 years, 4 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

Tagged: 

This topic contains 13 replies, has 4 voices.

Last updated by dbarber 2 years, 3 months ago.

Assigned support staff: Waqar.

Author
Posts
#1780627
Views 3.3 update.jpg

EDIT: I just checked the known issues log and found that it might be related to this (site uses Beaver Builder):

https://toolset.com/errata/fatal-php-error-on-sites-using-beaver-builder-after-updating-to-blocks-1-3/

I ran a number of plugin updates the other day, and one of the updates "killed" the website, so I restored it to a backup and then went about updating plugins, clearing cache, and checking on the website in incognito mode.

After updating to Views 3.3 and checking on the website, the website was down.

I restored the website from a backup but you can see what it looked like after the update in the attached image.

For what it's worth, the website was operational while I was logged in.

#1781027

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

Thanks for the feedback.

Did you get the PHP debug logs from your website?
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/#php-debugging

If you got the same PHP error as the erratum you mentioned above, please try the hot fix in it:
https://toolset.com/errata/fatal-php-error-on-sites-using-beaver-builder-after-updating-to-blocks-1-3/
A patch is available until the issue is resolved with a hotfix for Blocks ...

#1782737

As the client has a large audience of paying members, as soon as I saw the problem, I restored it from the backup I had just run before doing the updates (to revert Views to the previous version), so I did not have/take time grab any logs while the problem was active.

#1782843

I am experiencing the same issue on one of my sites. Strangely, my other sites on the same server don't have this problem.
No Beaver and no other page builders. I have tried also updating through FTP, deactivating other plugins except Wordfence. No matter what I do, Views 3.3 causes the white screen of death. Then WordPress sends me an email with the details:

////////////////
When seeking help with this issue, you may be asked for some of the following information:
WordPress version 5.5.1
Current theme: GeneratePress Child (version 0.1) Current plugin: Toolset Views (version 3.3) PHP version 7.4.9

Error Details
=============
An error of type E_ERROR was caused in line 125 of the file ...../public_html/wp-content/plugins/wp-views/backend/Services/Bootstrap.php. Error message: Uncaught Error: Class 'Toolset_Relationship_Role' not found in ...../public_html/wp-content/plugins/wp-views/backend/Services/Bootstrap.php:125
Stack trace:
#0 ...../public_html/wp-content/plugins/wp-views/application/controllers/main.php(92): OTGS\Toolset\Views\Services\Bootstrap->initialize()
#1 ...../public_html/wp-includes/class-wp-hook.php(287): WPV_Main->initialize_classes()
#2 ...../public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters()
#3 ...../public_html/wp-includes/plugin.php(478): WP_Hook->do_action()
#4 ...../public_html/wp-content/plugins/types/vendor/toolset/toolset-common/bootstrap.php(107): do_action()
#5 ...../public_html/wp-content/plugins/types/vendor/toolset/toolset-common/bootstrap.php(126): Toolset_Common_Bootstrap->__con

//////////

I don't use the Bootstrap thing at all.

#1782885
#1783561

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks Tom, @dbarber please check if it is the same problem of your website, compare the PHP debug logs, if it is, please try the workaround of the erratum:
https://toolset.com/errata/fatal-error-activating-blocks-1-3-if-there-is-a-pending-relationships-migration/

You setup a test site and test the workaround.

#1784879

I gave it a try, no luck.

After the database prompt, I saw there was warning message (below) but when I went to Relationships, there was no prompt of any kind.

Not sure if it's related but here's the database update error message:

> The upgrade process is starting...
> Precondition "correct database layer mode"... OK
> Precondition "toolset_associations table exists"... OK
> Precondition "toolset_associations_old table is not yet present (indicates manual database manipulation)"... OK
> Precondition "toolset_associations_new table is not yet present (indicates interrupted upgrade process)"... OK
> Precondition "toolset_connected_elements table is not yet present"... OK
> Precondition "able to create a new database table"... OK
> Precondition "able to delete a database table"... OK
> Precondition "WPML not active or in a good version (4.4.0 or above)"... OK
> Temporary migration tables have been removed if they existed.
> Created table "wp_toolset_associations_new".
> Created table "wp_toolset_connected_elements".
> Error when migrating association #301: Post #2688 doesn't exist. An association involving it will be skipped.
> Completed batch of 250 associations between #1 and #501.
> Completed batch of 250 associations between #507 and #775.
> Completed batch of 250 associations between #776 and #1066.
> Completed batch of 145 associations between #1067 and #1238.
> All associations have been migrated to the new temporary table.
> Maintenance mode enabled.
> Old and new association tables have been renamed successfully ("wp_toolset_associations" to "wp_toolset_associations_old" and "wp_toolset_associations_new" to "wp_toolset_associations").
> Database layer mode has been updated successfully.
> Maintenance mode disabled.

#1784973

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Please provide the database dump file of your website before the migration(Upgrading), I need to duplicate the same problem in my localhost, your can put the files in your own google drive disk, share the link only, private message box enabled.

#1794589

Can I just give you access to the staging version of the site?

#1794953

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Since it is a database problem, please backup your website first, then provide your website credentials and FTP access in below private message box, I still need to export your website database, test and debug it in my localhost

#1802545

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for waiting and for sharing the admin access.

Luo is on vacation so I'll be following up on this ticket.

I'm currently, reviewing the relationships on this staging website and will be running some tests accordingly. Will update you as soon as this testing completes.

Thank you for your patience.

regards,
Waqar

#1809771

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access to the staging website and I've managed to download its clone/snapshot to troubleshoot on a different server.

I'll be performing some tests on this clone/snapshot to investigate the issue and will share my findings, as soon as, this testing completes.

Thank you for your patience.

#1810907

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting.

While working on your website's clone, I was able to update to Toolset Views 3.3.1, following these steps:

1. I deactivated the WP Rocket plugin, as cache and optimization plugins can interfere with the updates, at times.

2. I went to WP Admin -> Toolset -> Relationships and saw a message about the pending database update. It completed without any issues and I saw the same log message as you shared in your reply.
( ref: https://toolset.com/forums/topic/site-went-down-after-updating-to-view-3-3/#post-1784879 )

3. After that I update the Toolset Forms to 2.6.1 version and also the Toolset Views to 3.3.1.
( I deactivated and deleted Toolset Views and then installed a fresh copy downloaded from the downloads page https://toolset.com/account/downloads/#legacy-plugins )

4. After the activation of the Toolset Views plugin, I didn't see any errors or warnings on the screen.

There are a few layout/structural differences, related to the functionalities from third-party plugins like Extender Pro and Beaver Builder, etc. To fix those, you'll need to make sure to update all plugins to their latest versions too.

Once, everything is working as expected, you can turn on the WP Rocket plugin again.

I hope this helps and please let me know if you need any further assistance around this.

#1811793

My issue is resolved now. Thank you!