Skip Navigation

[Resolved] Site Display Problem After Updating to Genesis 2.4

This support ticket is created 6 years, 4 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 20 replies, has 3 voices.

Last updated by dbarber 6 years, 3 months ago.

Assigned support staff: Minesh.

Author
Posts
#441548
genesis-2-4.jpg
genesis-2-3-1.jpg

I'm working on a new site and just updated the staging version to Genesis 2.4 and now the site display is "off."

Please see pics of production (using G 2.3.1) and staging (using G 2.4).

It seems that the "site-inner" class may be partially responsible for display issues on G 2.4.

All plugins are up to date and the site is using a child theme based on the Genesis Sample Child theme (I have tried switching from the child theme to Genesis framework, but problem remains).

#441785

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

1)
Could you please try to resolve your issue by deactivating all third-party plugins just to ensure that there is no plugin conflict?

2)
I need your theme in order to test with our plugins. Could you please share your theme zip, upload it to some file sharing services and share URL to download it.

#441794

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I've one user who resolves this issue by changing the structure:
=> https://toolset.com/forums/topic/update-to-genesis-2-4-0-breaks-layouts/#post-441364

Could you please try and check if this solution help you to resolve your issue.

#441980

Hi there

The user in the post you referenced didn't solve the problem. He/she actually identified it and expanded upon what the cause may be (markup change).

Support's response to that issue seems to indicate that you guys need to update Toolset plugins to address the issue.

So I think I should probably hang tight until after you guys have sorted this out.

Please advise.

#442241

Not sure if the following is the ideal workaround but it worked for me so I thought I'd share it.

Add this to the Layouts CSS

.content {
 margin-top: 0; 
}

Then add the script below to Genesis > Theme Settings > Header and Footer Scripts

<script>
!function ($) {
  $(document).on( 'ready', function() {
    $('.site-inner').each( function(){
      $(this).removeClass('site-inner')
    })
  })
}(window.jQuery)
</script>
#442441

The above workaround does not work with Better WordPress Minify active on a site, as I just learned.

#442569

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I apologise, but we're not compatible with Genesis 2.4 yet, we are working on the upgrade, but until the development work in not done I strongly recommend to downgrade to Genesis 2.3.

This is the flow to follow: disable all plugins, rollback Genesis and reactivate the plugins again.

I hope this helps and I strongly apologise for the inconvenience.

#444022

Wasn't sure what status to assign this as downgrading to 2.3.1 does the trick but technically doesn't solve the problem so, for the possible benefit of others, decided to set status to "I still need assistance."

#444029

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

OK - I'll update you when we are compatible with Genesis 2.4.

#445258

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Dawson

Minesh has a public holiday today.

I wanted to let you know the fix has been published with the release of version 1.7 of the Genesis integration plugin together with 1.8.6 of Layouts.

Keep an eye out for an update notifications on your plugins page.

If that doesn't appear or you don't want to wait you can download the zipped plugin files from your downloads page (wp-types.com/my-account/downloads). You can use the Upload button on the Add New Plugins page to add the zipped versions to your site, but that requires deleting the old plugins first.

If you have FTP access you can upload the unzipped files to your plugins folder and overwrite the old plugin version.

Please re-test the issue and let us know if you have any continuing problems.

#445831
after-update.jpg
before-update.jpg

HI Nigel

Thanks for the news.

Unfortunately, there are still some issues.

I was able to update Layouts but Toolset Genesis Integration won't update from 1.6 to 1.7.

After clicking on the Update button, it says it's successfully updated but after refreshing the page I can see that it's still 1.6 and I'm prompted to update.

I deactivated and deleted 1.6 and uploaded and activated a copy of 1.7 from the Toolset website, but I continue to see the prompt to update (which I do, see the success message, then refresh the page and see that it's still 1.6).

There continue to be site display issues (perhaps owing to not being able to update Toolset Genesis Integration?).

After updating to the latest version of Genesis and Toolset Layouts, the content class adds 60px margin to the top (can obviously be easily fixed via CSS but thought it was worth reporting).

Furthermore, there appears to be padding issue with column classes.

As you can in the the attached screenshots, before updating, the main content area and sidebar area were nicely separated.

After updating, they are not.

I firebugged it and see that the default padding-right for all columns is 5 px

.col-lg-1, .col-lg-10, .col-lg-11, .col-lg-12, .col-lg-2, .col-lg-3, .col-lg-4, .col-lg-5, .col-lg-6, .col-lg-7, .col-lg-8, .col-lg-9, .col-md-1, .col-md-10, .col-md-11, .col-md-12, .col-md-2, .col-md-3, .col-md-4, .col-md-5, .col-md-6, .col-md-7, .col-md-8, .col-md-9, .col-sm-1, .col-sm-10, .col-sm-11, .col-sm-12, .col-sm-2, .col-sm-3, .col-sm-4, .col-sm-5, .col-sm-6, .col-sm-7, .col-sm-8, .col-sm-9, .col-xs-1, .col-xs-10, .col-xs-11, .col-xs-12, .col-xs-2, .col-xs-3, .col-xs-4, .col-xs-5, .col-xs-6, .col-xs-7, .col-xs-8, .col-xs-9 {
    position: relative;
    min-height: 1px;
    padding-right: 5px;
}

As mentioned, perhaps both of these issues are due to 1.6 so perhaps when whatever's preventing the update to 1.7 is addressed - and I can update to 1.7 - these issues will be resolved.

#445836
before-update-small.jpg
after-update-small.jpg

Here are cropped screenshots.

#446865

Any updates on this?

#447296

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

We have released the new version for layouts as well as Genesis integration. Could you please update Genesis integration plugin to its latest official released version 1.7 together with layouts version 1.8.6.

*** Please make a FULL BACKUP of your database and website.***
You can download latest Toolset plugins from your account's download page:
=> wp-types.com/my-account/downloads

Please test your issue with this latest release and kindly report back if you still see any issue.

#447532

Hi there

I just updated (staging site) and the problems remain.

Genesis site-inner class adds 20px padding-top and content class adds 60px margin-top.

Bootstrap column classes default to 5px padding-right (while padding-left is 15px).

I know I can modify the properties / values through custom CSS, but that's obviously not a solution.

And I have checked for a plugin conflict by deactivating all non-Toolset plugins and the problems remain.