Skip Navigation

[Resolved] Single item content template does not show

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by matthiasV-2 9 months, 2 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#1949085

> Toolset access control > both for eigendommen and vakexperts > new subscriber > we unchecked the read permission and applied "what to display for single-posts when there is no read permission" - show content template - single item.

> Login with _testaccount_2, password: MzLTpoatq1@DBiZglKPMLCTh.

> Visit:
- hidden link > and click one of the 'meer informatie' buttons
The user should be redirected to the single item content template instead.

> Visit:
- hidden link > and click one of the 'meer informatie' buttons
Same goed here. The user should be redirected to the single item content template instead.

#1951533

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

Both of these links are for pages that use views:
- hidden link
- hidden link

And it is expected, the view will display, whatever you configured to display, for any type of user. Because Toolset Access rules are not applied on views, they are applied on the custom posts' single page. For example, if you take the following post, it won't be accessible for guest users as you can see in this screenshot hidden link
- hidden link

If you want to restrict the views for some types of users, you need to set the restriction on the page level. You can use Toolset Access Post Groups
https://toolset.com/course-lesson/restricting-access-to-pages/

I hope this answers your question! If you believe that I missed something, please provide more details.

#1951623

The restrictions are set on page level!
See the post types "eigendommen" and "vakexperts".

For hidden link (post type "eigendommen")

- If the user is a guest then he should be redirected to the login / registration page
- If the user is an Author or a new subscriber then he should be redirected to the single item content template

For hidden link (post type "vakexperts")

- If the user is a guest then he should be redirected to the login / registration page
- If the user is an Author or a new subscriber then he should be redirected to the single item content template

1. Log out
2. Visit:
hidden link
hidden link
You are redirected to the login / registration page - so that's OK.

1. Login with _testaccount_2, password: MzLTpoatq1@DBiZglKPMLCTh
This user has the role of author and new subscriber so he should be redirected to the single item content template
2. Visit hidden link and click "meer informatie" of one of the properties. The user is NOT redirected to the single item content template, instead he is redirected to the detailed property page!
3. Visit hidden link and click "meer informatie" of one of the vakexperts. The user is NOT redirected to the single item content template, instead he is redirected to the detailed vakexpert page!

Clear now?

#1952331

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Maybe we are having a misunderstanding in naming things, especially because the word page is very popular on the internet(a web page), and confusing in the WordPress community.

WordPress offers 3 default post types: Pages, Posts, and Medias, and allows to register(using code or a plugin such as Toolset) new custom post types.
- Pages have a strict URL scheme. A page with slug "contact" has the following URL hidden link
- Posts may have different URL schemes that can be configured in Settings->Permalinks.
- Custom Post Types have a strict URL scheme. A Product with a slug "hoodie" will have the following URL hidden link. This can be customized using rewrite rules or custom code. We can talk about this separately.

hidden link is not a post from the CPT "eigendommen", it is a post from the default post type Pages, or commonly saying a page.
hidden link is not a post from the CPT "vakexperts", it is a post from the default post type Pages, or commonly saying a page.
This means that the Toolset Access Controls on both CPTs "eigendommen" and "vakexperts" will not apply on these pages.

Now, let's take this URL hidden link This is a post from the CPT "eigendommen". Its URL is built based on the CPT slug "eigendom" and the post's "woning-berendrecht". The Toolset Access Controls on the CPT "eigendommen" should and must apply for this URL, otherwise, it is an issue/error/bug.
Does it make sense?

1. Log out
2. Visit:
hidden link
hidden link
You are redirected to the login / registration page - so that's OK.

This is not what I am getting. As a non-logged-in user, I am still able to view the pages. Check this screenshot hidden link
But when I visit a post from the CPT "eigendommen", I get the authentication form hidden link

Finally, please note that you are using the "Message - single item" template in the Toolset Access configuration hidden link
This template is already assigned to the CPT "Messages". I doubt that it is the one you want to use.

I hope this helps. I remain at your disposal.

#1952427

Instead of giving me a lesson of what a page is (or not) you could help by suggesting what post type EXACTLY I should change access control for in order to have "authors" and "new subscribers" redirected to the single item content template when visiting hidden link and hidden link when clicking "meer informatie"???

#1957651

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting and reading through the conversation I feel the confusion arose from the "single item content template" term.

In the access post type control settings, I see that you've set the "Author" and "New subscribers" role user to not have read access to "eigendommen" and "vakexperts" posts and instead see the content from the content template named "Message - single item". But this part is not working and the user of this role is still seeing the regular content on the single post pages.

To troubleshoot and investigate this matter, I'll need to perform some testing on your website's clone. Do I have your permission to download a duplicator package from the website?
( the Duplicator plugin is already installed )

#1958259

Please go ahead and perform the testing on a website's clone.

#1962477

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the permission and I've downloaded the duplicator package.

I'll be performing some tests and will keep you updated on my findings.

Thank you for your patience.

#1964429

Hi

Where you able to find and solve the issue?

#1965007

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting and I apologize for the delay in getting back on this.

Just wanted to let you know that I'm still running some tests and will be able to share my findings within the next few hours.

#1965569

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting, as this investigation took longer than I initially anticipated.

During troubleshooting, I discovered that the default role "Participant" from the "bbPress" forum plugin is responsible for this.

When a new user is created, the "bbPress" sets an additional role "Participant" to it.
( as can be seen in this screenshot hidden link )

And since in the Access post type settings, the read access is removed for the "Author" and "New subscribers" roles but not the "Participant", that user is still able to access those posts.
( screenshot: hidden link )

To overcome this, you'll need to remove read access to these post types for the "Participant" role too, same as the "Author" and "New subscribers" roles.

I hope this explanation helps.

#1965663

My issue is resolved now. Thank you Waqar!