Skip Navigation

[Closed] Sidebars disappeared after updates

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 7.34 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by Shane 5 years, 5 months ago.

Assigned support staff: Shane.

Author
Posts
#347147

I am trying to: Make the page display a sidebar, preferably without Layouts because I don't want to wrestle with adding the code for a custom post type and risk messing something up.

I visited this URL: hidden link

I expected to see: A sidebar like on this page: hidden link

Instead, I got: No sidebar at all.

This problem happened after a move between servers, loose update log from September follows:

Updated WordPress to 4.3.1
Updated theme the7 to 2.3.3 and then 2.3.4
Updated Plugins: Visual Composer, Dynamic Widgets, Popup Maker, Layouts, Types, WooCommerce, Redirection, Wordfence, WP Instagram Widget, WP Views

We also recently updated all WP Toolset plugins.

The most annoying thing is we don't have control over what widget area will show up in the sidebar space the page gets.

#347239

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Elizabeth,

Thank you for contacting our support forum.

This issue sounds more theme related than Toolset related because a theme normally dictates the widget areas that are available. Some themes go further by allowing specific pages to have their own custom widget. Not sure if your theme can do this but some themes can.

Specifically if your widget was created using views then you should be able to re-add the widget by going to Appearance -> Widgets.

I do also recommend that you contact your theme's support theme to see what they have to say about the issue.

Thanks,
Shane

#347741

Hm, well here's another problem I've been having that contributes to this being an issue. For some reason, the single-beer.php files I've been trying to use to add in the sidebars by force aren't working. They work fine on pages without Content Templates but are ignored when Content Templates are added. Is there a reason for this you can think of?

#347990

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Elizabeth,

I cant think of a reason why this should work because a contain templates only hooks into the section that displays the actual post content. The sidebar functions are left alone.

Could you provide me with an example where I can see this issue?

I'll enable the private fields so that you can provide me with the temporary admin credentials as well.

Thanks,
Shane

The topic ‘[Closed] Sidebars disappeared after updates’ is closed to new replies.