Skip Navigation

[Resolved] shortcode for Toolset View not rendering in LayerSlider slide

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Luo Yang 1 year, 9 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#1357371

I am trying to: Insert a Toolset view into a LayerSlider Slide

Link to a page where the issue can be seen: hidden link

I expected to see: I expected the Toolset View to be rendered

Instead, I got: It is just displaying the raw shortcode.

#1357629

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I have tried the URL you mentioned above, but can not see the problem you mentioned above:

It is just displaying the raw shortcode.

Is this problem resolved?
If you still need assistance for it, since it is a compatibility problem with "LayerSlider Slide", please provide a copy of your website, also describe detail steps to duplicate the same problem, where and how can I see the same problem, I need to test and debug it in my localhost, thanks

#1358077

So Sorry, Luo, but I was working on that particular page for a client & ended up removing the LayerSlider, which removed the issue from that page.

The main problem I'm having still exists. I'm not sure if it's possible, but I would like to be able to place Toolset Views into any of the various slide show plugins available for WordPress. Two different such plugins are commonly included with many WordPress themes. These are LayerSlider & Slider Revolution.

Both of these offer content editors for editing slides and then allow assembly of a series of slides into a show, which can be placed on any page with a shortcode or through a visual editor. LayerSlider includes an HTML block for adding HTML text tyo any slide. If I add HTML to a slide and that HTML includes the shortcode for a Toolset view, that view is not being rendered.

I have not tried this with Slider Revolution, but I would imagine that, unless those slide plugins use the standard WYSIWYG editor for inserting HTML, shortcodes in that HTML will not be processed.

I am wondering if anyone else has run into this problem and possibly solved it. If so, it would allow Toolset users to be able to insert customized, personalized, etc., content into individual slides, which would be significant.

#1358419

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I am not familiar with both plugins you mentioned above, but I have seen related thread about Slider Revolution:
https://toolset.com/forums/topic/i-need-custom-field-types-and-slider-revolution-2-work-together/
That user has provided a solution for displaying Views/Types shortcode in Slider Revolution, see it here:
https://toolset.com/forums/topic/i-need-custom-field-types-and-slider-revolution-2-work-together/#post-589012

For your reference.