Skip Navigation

[Resolved] Setting the login form layout to appear on the “My account” page for visitors

This thread is resolved. Here is a description of the problem and solution.

Problem:

The issue here is that the user wanted to setup a My Accounts page and set the correct permissions for it.

Solution:

For a tutorial on this you can take a look at the link below. https://toolset.com/documentation/user-guides/building-the-my-account-page/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 15 replies, has 2 voices.

Last updated by nathalieJ 2 years, 10 months ago.

Assigned support staff: Shane.

Author
Posts
#1177780
Screenshot 2019-01-04 18.08.34.png

Hiya

I am following this tutorial and I am stuck. It says:
5. Select Show Template Layout. Here, for users with restricted access, you can select a layout to display instead of the page content.

6. Choose Login Form, which is the name of the layout we just created.
7. Click Set errors to save your changes.
8. Save your post group.

I don't have the option when I click on the tick box so I am unable to select the login form. See attached

Thanks for your help!

Nathalie

#1177844

Can't delete so overwriting this comment. I posted it in the wrong thread sorry

#1177877

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Nathalie,

Thank you for contacting our support forum.

Did you manage to setup the content template that you want to show ?

YOu will need to add the login form to a content template then set your settings to a content template then select that content template.

Please let me know if this helps.

Thanks,
Shane

#1177901

Hi Shane,

Thanks for your quick response!

I'm sorry I don't make 100% sense of that (It's my English, not yours!)

I have a form on this page - hidden link

I followed this tutorial - https://toolset.com/documentation/user-guides/building-the-my-account-page/

No problem until I got to the bit where it says:
5. Select Show Template Layout. Here, for users with restricted access, you can select a layout to display instead of the page content.
6. Choose Login Form, which is the name of the layout we just created.
7. Click Set errors to save your changes.
8. Save your post group.

as I can't see this option when I tick the box that's next to 'Guest'

Hopefully I am making sense, English isn't my first language

Nathalie

#1179133

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Nathalie,

Would you mind allowing me to have access to this so that I can see what's up ?

Also could you send me a link to the content template that you would like to display.

Thanks,
Shane

#1179134

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

The private fields have been enabled.

Thanks,
Shane

#1179917

Oh everything seems to be working fine this morning. Thank you : )

#1180260

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Nathalie,

Awesome if everything is working then there is nothing else I can do :).

You can mark this as resolved when you're ready.

Thanks,
Shane

#1180383

Awww I am sorry Shane, I have just gone to the plugin page and seen that for some reason the Access plugin is disabled, and I am scared to activate it now as yesterday I couldn't get into the admin section of the site, it was redirecting me to the login page

I didn't disable the plugin I don't understand what happened. I also have content that go missing - This page was showing fine this morning for instance, I swear I haven't touched it since - hidden link

Nathalie

#1180815

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Nathalie,

What you can try doing is to re-enable the plugin and if there are any issues coming up you can just provide the credentials for the site so that I can have a look

The private fields have been enabled.

Thanks,
Shane

#1180966

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Nathalie,

Sorry to hear about your decision, however you can change your site key by removing the previous one from here
https://toolset.com/account/sites/

Thanks,
Shane

#1180985

Thanks Shane, does it mean that if I amend the site link, I won't be able to see what I have done on the previous one anymore?

I'd rather not have to start it all from scratch I have been on this for a week! (Yes I know)

#1180988

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Nathalie,

No, all changing the link here will do is allow the previous site not to be able to get the automatic updates.

It will not delete anything that you've worked on so far.

Thanks,
Shane

#1180996

Awsome!!

Thanks for your quick responses, Shane : )

#1180999

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Nathalie,

If there are no further issues then you can mark this ticket as resolved.