[Resolved] Set authot of a custom post type

Hi, Amit here, I am the Toolset Support Manager, our current ticket queue is calm and I'd like to encourage you to use our new chat support option

In order to try it out please notice that when you open a ticket (while there's availability) you will be able to choose between chat and a normal ticket, both lanes lead to the same supporters and if we decide in chat that the issue needs more time we'll transform it into a normal email ticket for you, so nothing is lost

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Shane 3 months, 3 weeks ago.

Assigned support staff: Shane.

Author
Posts
#1134957

Hi,

I created a custom post "accommodation".
I used also Access to create a custom role "property manager"

I've many users with "property manager" role.

I need to set for eachone an accommodation.

I'm trying to set the user "property manager" as autohr of custom post type accommodation, but I don't see the users in the option list. I see only Administrator role users and not "property manager" users.

I set for "property manager" role all capabilities available but nothing change.

Can you help me?

Thank you

#1135093

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Domenico,

Thank you for contacting our support forum.

Does this user role have edit or publish privileges for this cpt ?

If not then this could be why it isn't working.

Please check this and let me know.
Thanks,
Shane

#1135095

Yes Shane, the user has all the privileges.
I selected all..

#1135138

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Domenico,

Would you mind allowing me to log into the site to check on this for you ?

The private fields have been enabled.

Thanks,
Shane

#1135155

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Domenico,

Not sure why your role wasn't working as intended.

However it should be working now. What I did was to create a new Property Manager role and set it to copy the permissions from the Author wordpress role.

Please let me know if it helps.

Thanks,
Shane