[Resolved] Relationship form submit button no longer works

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Michelle Dodd 1 month ago.

Assigned support staff: Waqar.

Author
Posts
#1645709

I have a single CPT page with several relationships/intermediary posts connected to the main CPT (called HCCN). The submit button that the relationship form added automatically stopped working - it no longer contained a label on it so it was blank. I found a workaround on your support forums to instead use this:

[cred-form-submit]Submit[/cred-form-submit]

However, nothing happens and no connection is made with this button either. This is a critical issue as the form needs to go out before end of day Monday! Please help.

Link to a page where the issue can be seen:

hidden link
sitewide password: "collaborate"

This is a staging site, feel free to change things around as needed.

In order to get the Add New and Edit forms, I followed your advice on this post:
https://toolset.com/forums/topic/cant-add-a-link-to-edit-relationship-form-template/

#1645807

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Michelle,

Thank you for contacting us and I'd be happy to assist.

Your observation is correct and the issue of the missing default label for the relationship form submits button has been reported to the concerned team already.
( ref: https://toolset.com/forums/topic/submit-button-not-displaying-correctly/ )

If you're referring to the form usage at "Add Electronic Health Records Systems" ( at yourwebsite.com/form/add-ehr/ ), I noticed that the child post-selection field "HCCN" is hidden.

As the value of a child post remains un-selected, the form doesn't work to add a new connection.

To avoid this, you can follow these steps:

1. You can update your form's shortcode on the page, to listen to a URL parameter value, for example, "hccn-id" to get the target "HCCN" post's ID:
( ref: https://toolset.com/documentation/user-guides/views/views-shortcodes/#wpv-search-term )

Current form shortcode:


[cred-relationship-form form='manage-ehr-form']

Updated form shortcode:


[cred-relationship-form form='manage-ehr-form' child_item='[wpv-search-term param="hccn-id"]']

Once you'll visit the same page, with this URL parameter and the HCCN post's ID ( for example yourwebsite.com/form/add-ehr/?hccn-id=1389 ), the child post's field will be automatically selected in the hidden field.

2. In the content template for the single HCCN post, where you've added a link to this new connection page, you can update the link to include the current post's ID in the URL parameter:


<div class="list"><a href="[wpv-post-url item='1895']?hccn-id=[wpv-post-id]" class="et_pb_button">Add an EHR</a></div>

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#1646517

I edited the Content Template for each of the Edit relationship forms to add the code: ?hccn-id=[wpv-post-id]

This worked and now I can edit the relationships and save them. Thanks!

However, I can no longer save anything on the Single HCCN template so I can't change the code in step 2 for the links to Add relationships.

I turned off all plugins besides the Toolset plugins and changed to the default WP Theme, which worked before, but now it is not. I can't make any changes and save.

🙁

Could you please help again? I'm almost done

#1646797

Oh please help.

I made a copy of the Single HCCN template, made the addition to the Add EHR link to include ?hccn-id=[wpv-post-id] and then I was able to make the duplicate Single HCCN the active template and still this is not working.

Also, I had tested the Edit EHR link and made the changes you suggested, but now they are not working! What the heck? It's like things are changing even when I don't have templates open.

#1646999

OK, I've now got the Edit and Add relationship forms working through trial and error - I didn't realize I needed to update the embed form code in both the Add and Edit page/template.

Now, the Single HCCN page is no longer displaying the intermediary post data for each relationship, whether added or edited. This was previously working, but is no longer. If I add or edit an intermediary post and save, it will show the changes in the radio buttons, but none of the checkboxes are saving data.

I don't understand why this was working and not is not - I didn't change anything in the intermediary posts, though now I'm trying to fix and can't figure it out.

I'm working with the two test posts:
hidden link
hidden link

You can add or edit anything on these posts.

Thanks,
Michelle

#1647021

I just found this - is this the reason the checkboxes will not save for the intermediary posts?

https://toolset.com/errata/custom-checkboxes-fields-are-not-saved-in-post-relationship-forms/

This is a very serious issue for me. This completely changes my project if it's true. I don't know what I'm going to do now.

#1647151

I'm very unhappy that it took getting all the relationship forms hooked up to find out that checkboxes don't work on intermediary posts. I spent a shit ton of hours doing all these relationships and fields and had to redo everything. Many many hours wasted. It's not like anyone is going to read through an entire list of known issues before they figure out their approach. You should add a warning when someone tries to use checkboxes on intermediary posts. I'm extremely tired and frustrated.