Skip Navigation

[Resolved] Problems with DIVI and Toolset with the classic editor.

This thread is resolved. Here is a description of the problem and solution.

Problem:

In order for DIVI to work correctly with Toolset, I must enable the "classic editor" in the DIVI configuration. The problem is that for some circumstance when entering a page initially it is very slow to work with the configuration of the modules, sometimes the page is reloaded without explanation.

Solution:

This is a Divi theme issue, it happens even without any other plugins.

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 15 replies, has 2 voices.

Last updated by Francisco Ramón Molina Busquiel 7 months, 1 week ago.

Assigned support staff: Luo Yang.

Author
Posts
#1420503

Hi,
In order for DIVI to work correctly with Toolset, I must enable the "classic editor" in the DIVI configuration.
The problem is that for some circumstance when entering a page initially it is very slow to work with the configuration of the modules, sometimes the page is reloaded without explanation.
The video page is: hidden link
Watch the video that I attached: hidden link
How can I improve this?
Thanks for your help.
Regards,
Jose

#1421465

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Jose,

Thanks for the details, I can log into your website, but I do not see the same problem as your video, I can open that text module within 1 second, see screenshot text1.JPG.

It might be a browser cache problem, please try to clear your browser cache or try with another browser, and test again.

#1421557

Luo,
But a screenshot indicates nothing about loading problems and even random form refresh. Before sending you this problem, I tried it with many browsers and on different computers. The problem manifests initially and is quite terrible.
I send you another video (hidden link), this time using the Firefox browser, as you can see the first time I try to open the module properties does not work until after a while, after opening it initially, the following times it works faster. Now I have been lucky and there has been no random form refresh, which would still hurt more.
This is something you have to solve urgently.
Regards,

#1422679

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have tested it again, but can not see same problem, see my video capture:
hidden link

I suggest you try these:
1) In your video, you are using another user "Admin", but I am using user "pruebas", it might be a problem, please test with the user "pruebas", you can get it's credentials in your private message box:
https://toolset.com/forums/topic/problems-with-divi-and-toolset-with-the-classic-editor/#post-1420503

2) Check if there is any JS/PHP errors in your website:
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/

3) Deactivate other plugins/custom codes, and test again.

If you still need assistance for it, please provide a copy of your website in below private message box. I need to test it in my localhost

#1423157

Hi Luo,
You have tried to do the following:
- Restart the computer.
- Open the browser
- Open the page
- Open the properties of the DIVI module
Tell me if it works correctly by doing these steps.
Thanks,
Regards,

#1424069

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have tried the steps you mentioned again, I am using Chrome incognito window, there isn't the same problem.
Did you get any JS/PHP errors logs?
Can you try these:
1) Deactivate all Toolset plugins
2) Try it again, check if the problem persists.
If it still persists, then it is not related with Toolset.
If it does not persist, please provide a copy of your website in below private message box.

#1424723

Hi Luo,
Disabling Toolset works fast, and even if it continues to work slowly, directly or indirectly, the problem will always be related to Toolset, because by Toolset and compatibility with it, I have to have the "Classic Editor" mode connected.
Now with DIVI the "Classic Editor" mode should never be used, except for force majeure.
Watch the following video with Toolset disabled: hidden link
In my dashboard in duplicator you can find a backup of my site, download it.
Thanks for your help.
Regards,

#1425495

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I am downloading the files, will update here if there is anything found

#1425709

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

In my localhost, I see different from your video:
1) After with or without all Toolset plugins, I see the same problem:
- Try with a new Chrome incognito window
- Edit the problem page Boletín
- Edit the text module, it does not work in first time, but it works in the second click

2) After deactivate all plugins including Toolset plugins switch to Divi original parent theme, I see the same problem:
- Try with a new Chrome incognito window
- Edit the problem page Boletín
- Edit the text module, it does not work in first time, but it works in the second click

Can you confirm it?

#1425887

Luo,
In the first case I had to do even 3 clicks to be able to show the module properties window.
In the second case, as you say, I had to make 2 clicks.
What do we do now?
How can we solve these problems?
Toolset forces you to use the "classic editor" and this is a problem.
Regards,

#1425921

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I suggest you check it with Divi support for the second case, there shoud be a bug in Divi theme, and it conducts those problems, can you report it to Divi support?

For the question:
Toolset forces you to use the "classic editor" and this is a problem.

I don't have other workaround for it.
This is mentioned in our document:
https://toolset.com/documentation/recommended-themes/toolset-divi-integration/

To use Toolset within the Divi Builder you must disable The Latest Divi Builder Experience. To do that to go to Divi -> Theme Options, click the Builder tab and in the Advanced section disable The Latest Divi Builder Experience and enable the Classic Editor option.

And in our blog we have already confirmed: there are some compatibility issues with Divi 4 theme:

we recommend to our clients to stay with Divi 3 on sites that have both Divi and Toolset.

#1425925

That is, you tick your hands. Fabulous. A wonderful support.
This is unfortunate. Very unfortunate. 🙁

#1427207

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The problem persists even only with Divi original theme, without any other plugins, so it is a Divi theme problem, according to our support policy, it is out the range of Toolset support:
https://toolset.com/toolset-support-policy/

As I suggested above, you need to concact Divi theme support for it.

#1427393

Hi Luo,
From what you're saying, I get the feeling that you haven't talked to Amir.
He offered me special help / collaboration.
Check out the latest comments on this blog of yours.
https://toolset.com/2019/12/learn-how-to-build-templates-archives-and-views-with-blocks/
Ticket conversion:
https://toolset.com/forums/topic/help-for-web-conversion-from-divi-4-to-toolset-using-only-blocks/
The idea was that you help me from support very quickly to demonstrate that the design of my website could be done with Toolset blocks, since Toolset with DIVI forces to enable the classic DIVI editor, which causes problems in the management of DIVI modules, since you did not have time to improve compatibility with DIVI and you were focused exclusively on improving Toolset Blocks.
Amir was convinced that the design could be converted to Toolset Blocks and finalized the conversion on the specified date.
I put my objections, however, yesterday I lost all day creating a clone of my site and trying to start the conversion, but I found many obstacles, it is assumed, as Amir told me, that you had to put 100% of your efforts to achieve the goal, however, if it is not so, because what I was supposed to have turned out, I have lost a whole day of work for nothing.
Regards,

#1430801

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

It is a Divi theme issue, according to our support policy:
https://toolset.com/toolset-support-policy/
We cannot fix Divi theme issues.

And we can help you to migrate your website from Divi theme to another theme we commeneded, I can see you have already created a ticket for it:
https://toolset.com/forums/topic/help-for-web-conversion-from-divi-4-to-toolset-using-only-blocks/
Waqas is working on it.

And according to our support policy, we prefer one ticket one problem, I suggest you create different ticket for different problems.