Skip Navigation

[Resolved] Problem with Toolset Access

This support ticket is created 3 years, 6 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+00:00)

This topic contains 3 replies, has 2 voices.

Last updated by deanL 3 years, 6 months ago.

Assigned support staff: Nigel.

Author
Posts
#1254165

I created a profile page for users with "Contributor" role to view their profile as well as stories they had contributed to the website: hidden link

Non-logged in users will see the login/register form.
Users with "Contributor" role will see their personal profile (managed with CPT called "profile")

I'm using Access to manage the output, here's how my code looks:

[toolset_access role="Guest" operator="allow"]
[wpv-post-body view_template="register-login-forms"]
[/toolset_access]
[toolset_access role="Guest" operator="deny"]
<div class="row">
<div class="col-md-4" style="padding-bottom: 40px;">
<h3>My profile</h3>
Hello [wpv-user field="user_login"] (<a href="/edit-profile/">Update login info</a>).
Not you? [wpv-logout-link]Logout[/wpv-logout-link]
[wpv-view name="my-profile"]
</div>
<div class="col-md-8" style="padding-bottom: 40px;">
<h3>My stories</h3>
[wpv-view name="stories-by-user"]
</div>
</div>
[/toolset_access]

The problem Im facing now, when I tried to log in as contributor, I can't see the view [wpv-view name="my-profile"] — it shows "Permission denied".

How do I go about troubleshooting this?

P/s: As the site is live, it is rather pressing for me to fix this quickly. It would help greatly if you can log in to take a look at my Access settings.

#1254197

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Dean

I'll take a look at this now.

Do you have a test contributor account I can use?

I'll set another private reply so that you can share that, too, if you have one available.

#1254669
#1254971

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Dean

Your View "My Profile" in the output section for when no posts are found includes a Toolset Form.

But in your Access settings Contributors did not have rights to use that form, and that's why you were seeing the "Permission Denied" message.

I added the rights for Contributors to use the form (at Toolset > Access Control > Toolset Forms) and it's now working.

#1254987

Thank you so much Nigel! You are my super star!