Skip Navigation

[Resolved] Prefilter filters on term archive page 2

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by romanB-3 1 year, 2 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#1743561

Hi,

On this post https://toolset.com/forums/topic/get-terms-from-children-posts-2/, Waqar found out there was empty spaces and break lines breaking the code on some of my pages, and the view didn't work properly.

On this view : hidden link (hidden link), I notice the same bug again, and can't find how to solve the problem.

In deed, for that term I don't have any Etablissement with the "Très bonne qualité" label. Therefore, the filter should display this choice as [deactivated].

Thank you.

#1743923

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

It is a custom codes problem, please provide your website credentials + FTP access in below private message box, also point out where I can edit your PHP codes, I need to test and debug it in a live website

#1744013

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

option1.JPG

Please elaborate the questions with more details:

or that term I don't have any Etablissement with the "Très bonne qualité" label. Therefore, the filter should display this choice as [deactivated].

I have checked the URL you mentioned above:
hidden link

click the "Classement ministère (2019)", the option "Très bonne qualité" is in deactivate status, see my screenshot: option1.JPG

Where and how can I see the problem you mentioned above?
the same bug

#1744023

It seems one of the called views didn't have the

[wpv-filter-meta-html]

in the output, and that caused the bug. I don't quite understand how this could be the problem, but adding the code back solved it.
Thank you.