Skip Navigation

[Resolved] POST_PARENT_TITLE doesn’t work after migration to Types3 and new relationships

This thread is resolved. Here is a description of the problem and solution.

POST_PARENT_TITLE doesn't work after migration to Types3 and new relationships

This is known issue to us and the fix will be published with next release of forms.

You can find proposed solution, in this case, with the following reply:

Relevant Documentation:

This support ticket is created 4 years, 3 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by thomasD-2 4 years, 2 months ago.

Assigned support staff: Minesh.


I updated an existing site to Types 3.01 and the other current toolset plugings. So far, everything worked fine.
Then I migrated the relationships, and afterwards the problem occured:

The CRED post form is using the placeholder %%POST_PARENT_TITLE%% in the subject line of the notification email. Before migration this worked fine. After the migration the placeholder doesn't work anymore - neither in the subject line nor in the email body. It's just an empty output.



Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Well - I would just like to confirm here - you have child form added to parent post - correct?

As well as - on what action you set your email notification - on form submit? could you please send me screenshot of your edit form page?

FireShot Capture 8 - Edit Post Form ‹ DEV YogaHa_ - https___dev.yogahaus-ekholm.de_wp-admin_post.php.png

Please find the screenshot of the edit page attached. The email message is sent on form submit. And the form adds content to the child post.
What do you mean with "child form added to parent post"? How can I do that? However I didn't change anything besides migration of the relationships, and the placeholdr in the Mail stopped working.
Thx for your support.



Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

What do you mean with "child form added to parent post"?
Well - actually I would like to know where the form is added.

Could you please send me problem URL and access details.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important. If you agree to this, please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP).

I have set the next reply to private which means only you and I have access to it.



Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Yes - I'm able to reproduce this issue. I'll report this issue to our Devs please hold on for further updates.



Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - I have workaround to offer you for now.

I've added following Generic hidden field - that eventually hold the parent ID to your Form:

[cred_generic_field field='@veranstaltung_anmeldung-veranst.parent' type='hidden' class='' urlparam='']
"default":"[wpv-search-term param='parent_veranstaltung_id']"

Now, when I submit the form - I see parent post title displayed just fine. Could you please confirm.


Thx. You're still logged in to WP and you are blocking the form. So please log out and let me check the workaround.

Have you found the root cause of the bug? Will there be a bugfix in the near future? (as I have experienced the same bug in 2 other Toolset installations).



Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Ok - I logged out and yes, the issue is already known to us and escalated to Devs and the fix will be proposed in near future release.


Thank you for your support.



Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

would like to update you that fix has been shipped with Toolset Forms version 2.0.1.


Hey Minesh, thanks for the information. I've updated to Forms, but the result is, that the form does not send any emails at all. Even the email test functionality responds "not allowed" when trying to send a test email. It's a bit annoying.

This is just for your information. I don't need support in this case, as I will stop investing time in this problem and I will skip the toolset migration (and maybe the usage of Toolset at all).