Skip Navigation

[Resolved] Post with child posts and/or field table is redirecting

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 8.26 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 3 voices.

Last updated by willem-siebeS 6 years, 6 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#220366

Very similar to this topic, which I see never got fully resolved:
https://toolset.com/forums/topic/post-type-with-child-relationship-is-redirecting/

I have the same issue occur where suddenly the following URL (parent type of "techwomen-mentee"):
hidden link

Is redirecting to the first of its child pages (child type "job"):
hidden link

I did have the Redirection installed, and was able to fix the issue by de-activating Redirection, clearing out all non-WP redirects in .htaccess, and then resetting permalinks in Settings > Permalinks. At this point things seemed to be working okay again.

Then I added back my .htaccess redirect, and things still worked fine.

Then I added reactived Redirection, and things still worked fine.

Then I reset permalinks again, and things still worked fine.

So with Redirection and my .htaccess redirects in place, everything seemed to work fine.

Then after a while, things broke again and the unwanted redirection started back up. Hard to say exactly when this happened, but it seemed to happen right after I edited a custom fields group that is attached to the parent post type. I accidentally had the same slug for two of the custom fields, which popped up a warning. I removed the second custom field and resaved. When the page reloaded, I realized several of my custom fields were missing (although this could have also been due to inadvertently refreshing). I then went to my single parent custom post "Test Mentee" to re-add data for the missing custom fields, and after saving and viewing the page I realized the redirection issue was happening again 🙁

Not sure what's going on, and this could very well be Redirection issue still. That said, things were working fine with Redirection enabled. Does the plugin cause this issue only at certain times/actions (saving, editing custom fields, etc)? Any ideas on how to solve this issue?

I'll try keeping Redirection deactived to see if the problem arises again. In the meantime I'd love some more details on what exactly causes this issue and if you have any updates.

Thanks!

#220811

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hi Kristin,

Are we talking about the plugin download from:
http://wordpress.org/plugins/redirection/
I just tested it in my localhost, it stores value in a custom database table "wp_redirection_items", which is not possible be handled within Toolset
I suggest contact ask help from the plugin author.

#220830

Yes I am talking about that plugin - you can reference the other thread I linked for more details. I've just uninstalled the plugin and things seem okay. . . for now 🙂

#285888