Skip Navigation

[Resolved] Possible conflict with Woocommerce columns/grid width on Woo product archive

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by martinE-4 11 months ago.

Assigned support staff: Minesh.


I am trying to: follow Toolset Woocommerce tutorial for creating a custom Product Archive with toolset -

Link to a page where the issue can be seen:
this is local but I have uploaded some screen shots

I expected to see:
my two product grid columns should go right across the layout and also the proper margin for the toolset archive

Instead, I got:
only a portion of the layout is used (50%?) - also zero margin

- I noticed that if I unchecked the woo commerce css for margin, then the toolset margin/padding was used. (see first and 2nd screenshots)
- I can't see what css is responsible for the grid width issue though (3rd screenshot shows a lot of detail...)

I wonder if the Toolset archive block can be made to override the woo commerce css (shouldn't that happen automatically with a !important when we use the block?)
Same for the grid width problem? There is some interference going on.

I tried the 2020 WP default theme and it is the same issue so it is not theme based...
Also I tried other Loop styles for the WordPress Archive loop and they all are restricted to half the archive page...

As I was writing this ticket, I thought of possible interference in the WP Customizer-->Layout-->WooCommerce-->Product Columns
It was set to 2, but if I set it to 1, then Toolset was able to insert it's grid into the whole space.
So that fixed the grid width issue (although I still think Toolset should override that setting automatically... and/or it should be documented in the tutorial)
However, the margin is still using the WordPress Customizer values for the Layout-->Container-->Content Layout padding, which negates/overrides/ignores any setting that Toolset tries to set for the archive loop.

I used GeneratePress and Toolset and Woocommerce (all latest plugin versions) on wp 5.6 PHP 7.4.1



Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Martin, thanks for sharing update and glad to know that you found the workaround.

But what steps I will require to follow if I would like to reproduce this issue on brand new WordPress site having all required plugins installed and activated.

Can you please share those steps and I would be happy to pass this to our next level support for further troubleshooting.

If you have another idea that rather sharing steps, duplicator will be quick and useful, please share duplicator package with problem URL.

As Christmas is near, most of our staff is on holidays but in the mean time I will file a ticket and hopefully our Devs get back to you with some good news in 2021 (new year) 🙂

I have set the next reply to private which means only you and I have access to it.


My issue is resolved now. Thank you!

It turned out to be a conflict with GeneratePress Premium - you have to be careful with the WooCommerce option of GP Premium with Toolset because it overrides the column settings of Toolset. Just set the columns to 1 and it should be fine. Most of the GP Woocommerce options do not work. A nice one is the display number of items in the cart beside the icon though, so that is a nice feature.