Skip Navigation

[Resolved] Plugin Download failed. (SSL certificate problem)

This support ticket is created 8 years, 2 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 3 voices.

Last updated by Stephen 8 years, 2 months ago.

Assisted by: abdallah.d.


I am trying to: Update Toolset Plugins

I visited this URL:

I expected to see: Plugins updated successfully

Instead, I got: Download failed. (SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)



Hi there,

I'm investigating this issue further. It may be related to your server setup, you can check/fix it per the following instructions.

If possible, please contact your hosting provider and ask them to update the bundle of CA root certificates.

If it helps, the curl website has the latest CA root certificate bundle available for download per hidden link
You can download the .pem and save it where your PHP installation can access it.
Then you just need to edit your php.ini file to tell curl where you saved the .pem file.
example: curl.cainfo=/home/mydomain/cacert.pem

It's probably much easier to ask your hosting provider to do that for you 🙂

Let me know how it goes!


As DEV team requested, I would need to request temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important

Please could you provide me the additional Infos?

Thank you for your patience.


I apologize the delay here

As this user reports, updating to PHP 5.4 solved the issue.
Also, WordPress now recommends PHP 5.6 and I would recommend to contact your server Admin to gently ask if a update would be possible (if you are not already running a newer version)

Please don't hesitate to inform me in case the issue persists

Thank you for your patience.



Hi there,

I see your server's PHP was updated to :5.6.12
I tried the update for Views and Layouts and both updated to the latest version without error.

Let us know if you need further assistance 🙂

Thanks, Abdallah


Hi Abdullah,

The site was migrated to a different server this morning and everything seems to be working.

Thanks for your help.


This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.