Skip Navigation

[Resolved] Please reopen: Views displays empty loop for event calendar

This thread is resolved. Here is a description of the problem and solution.

Problem: When Astra Pro, The Events Calendar, and Beaver Builder are all active together, one of my Views is returning "No results found" unexpectedly.

Solution: Update to the latest
version of Views to get the fix for this problem.

This support ticket is created 3 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 14 replies, has 2 voices.

Last updated by dbarber 3 years, 6 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#1248427

I am trying to: get Views to display a custom loop from Modern Tribe's Event Calendar

Link to a page where the issue can be seen: Password protected

I expected to see: output of the View

Instead, I got: No items to display

Please note that I did have a support ticket open over this issue but it was closed.

#1248543

I can't reopen a closed ticket, but I can try to help you here. Has something changed since the ticket was closed? Do you have new information to share?

#1248681

No, nothing has changed.

Views will not output Event Calendar unless I set the content selection type to both Events and something/anything else.

The problem seems to be a conflict with Beaver Builder and/or Astra Pro plugins.

I know that Toolset and WP Astra (the theme we're using and also the developer of Astra Pro) are well integrated so I was hoping that a solution would be possible.

We hit a roadblock before because I'm using premium versions and am obviously unable to share licensing credentials.

#1250363

We hit a roadblock before because I'm using premium versions and am obviously unable to share licensing credentials.
I probably don't need licensing credentials, I can work with just the plugin files. You can zip up your plugins directory and post that somewhere for me to download if you'd like, or you can post a new Duplicator package that includes all the plugins currently active on the site where the problem can be seen. Any URL you share here in a forum reply will be obfuscated from all other Users to protect your privacy.

#1250543

Can I just send you login credentials to the development version of the site?

#1251947

Yes, if it's okay for me to install the Duplicator plugin on the development site to create a clone, I will be glad to work from the development site. Please provide those login credentials here in the private reply fields.

#1255539

Sorry, but I will also need to send you login credentials to access the site. Access is currently restricted.

#1257071

Private reply fields are active here.

#1264687

Okay I was able to create a clone of your site and run some additional tests locally. If Astra Pro and the Astra theme (or a child of Astra theme) are active, the problem can be demonstrated. If either of those are deactivated, the problem is resolved. So that confirms basically what we learned in the previous ticket. Now that I have access to the Astra Pro plugin and The Events Calendar, I can run some additional tests tomorrow to determine if this is an issue that can be replicated, or if it's an exception (specific to your site). I'll keep working on that and let you know what I find out. Thanks for your patience.

#1264751

Sounds good. Thanks for your help, Christian!

#1265991

This is driving me crazy, because yesterday I was able to reproduce the problem on my local copy of your site with only Astra Pro, The Events Calendar, and Toolset plugins active. Today I cannot, and I feel like I'm chasing my tail. I'll continue investigating but I'm not confident I can pin down any one problem here.

#1266121

I'm glad that I'm not alone in being driven crazy by this thing!

The same problem is evident on another client's site, so it's definitely not isolated to this particular installation.

Anyway, thank you again for your help.

#1266933

Okay I was able to get to a point where I can hand off the materials to my 2nd tier team for further investigation. I'm waiting for their feedback now and will let you know what I find out.

#1281875

Hi, my 2nd tier support team has informed me that this issue should be resolved in the latest release of Views 2.4.8. Please update all your Toolset plugins to the latest versions and let me know if the issue is not completely resolved. Thanks for your patience!

#1287973

Hi Christian

Sorry for the late reply.

I've updated to the latest versions and I can report that I am now able to display Views of events without needing to select an additional content type, so it looks like the problem has been solved.

Big thanks to you and to the Toolset team for your perseverance!