Skip Navigation

[Closed] Permission issue/server error with module manager

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by emerson 7 years, 2 months ago.

Assigned support staff: emerson.

Author
Posts
#197672

Hi,

Using Toolset Bootstrap theme, I tried installing modules from the Modules Library, but get the following error

You don't have permission to access /wp-content/themes/bootstrap-theme/embedded-modules-manager/library/install_module_library.php on this server.

I have changed the file permissions to 777 and this error still occurs.

Many thanks in advance

Joff

#197930

Dear Joff,
Thanks for reporting this. First, ensure that you are using the latest version of Toolset Bootstrap theme which should be version 1.1. And clear your browser cache first before logging-in again to WordPress admin.
Then to import modules from our reference sites, you need to have Types and Views plugin activated. These plugins are required to have a successful import. Please also use the latest version of these plugins as available in our downloads page: https://toolset.com/my-account/downloads/
Then after activating Types and Views, try importing a module. If you still see this error, please check the following:

a.) Ensure that your WordPress account has read and write access to your WordPress files. Check this guide:
http://codex.wordpress.org/Changing_File_Permissions

This is usually an issue with your web host assigning incorrect permissions to your files. If you are not sure how to do this, please try contacting them and have the permissions set correctly.

b.) Where did you run the 777 permission? (on what file and folder) Sometimes this don't work if you still don't have the rights to change permissions. So they are being ignored.

If any of these suggestive actions does not work, I have enabled the "private details box for this issue" (you should see it at the bottom of this form). Then I'll check your site and do some debug. Make sure that you already have some backups of your files and database. And also provide an SSH access to your server so I can see how the permissions in your WordPress files are being implemented. Thanks. a lot!

Cheers,
Emerson

#197931

Dear Joff,
Also another thing to check is that if you have some third party security plugins restricting the access for these files. Or your site is using a security solution (via .htaccess, etc.) blocking write access for the installation. Please also check this out. Thanks.

Cheers,
Emerson

The topic ‘[Closed] Permission issue/server error with module manager’ is closed to new replies.