Skip Navigation

[Resolved] Parametric Search no longer working

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by rubenB 4 years, 3 months ago.

Assigned support staff: Shane.

Author
Posts
#473195

Hi, since a recent update, our parametric search no longer works as expected.
hidden link

Searching from Tetun language version of sitereturns the correct results in the site default language of English.

Appearance > Widgets > WP-Views-Filter
in both languages shows:
"There are no Views with a custom search. You can add them here. Remember that only Views forms containing a Submit button can be used on a widget"

Our View does in fact have a custom search, or atleast it did.

This makes me confused as to where to start looking for the problem, as there hasn't been any changes to the content whatsoever. Perhaps there is something you are aware of that needs changing since the updates?

#473545

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Ruben,

Thank you for contacting our support forum.

Were you able to resolve this as I checked on the parametric search and it was searching normally?

Please let me know.

Thanks,
Shane

#473753

Hi Shane, thanks for having a look -

When I use the parametric search form on
hidden link
(Tetun Language Version)

It returns me to the correct search results, however reverts to the English Language Version of the site eg:
hidden link

I've got the same results in Chrome and Firefox.

Are you getting a different result from me?

#474127

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Ruben,

I was able to notice this issue.

Would you mind providing me with admin to the website so I can have a look at the issue through the backend.

The private fields will be enabled for your next response.

Thanks,
Shane

#474588

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Ruben,

Could you try temporarily disabling all the non-toolset plugins leaving only the WPML plugins enabled along with toolset to see if the issue still remains.

Looking forward to hearing the results of this.

Thanks,
Shane

#475121

Hi Shane,
I temporarily disabled all plugins except Types, Views and WPML Multilingual CMS,
and received the same result,
any other ideas?

#475498

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Ruben,

The forum is a bit loaded at the moment but i'll update you as soon as I can.

Thank you for the continued patience.

Thanks,
Shane

#476582

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Ruben,

Would you mind providing me with a duplicator package of the website so that I can perform some more advanced debugging steps?

To provide the duplicator package please take a look at the link below.

https://toolset.com/faq/provide-supporters-copy-site/

Thanks,
Shane

#477178

Hi Shane, I've prepared a duplicator backup,
You can find it on our server which you have access to, or if you have a preffered method i can send it to you directly. You might decide not to restore the uploads folder, its really big.
Thanks!

#478433

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Ruben,

Thank you and sorry for the Delay.

I'll let you know as soon as possible what i'm able to find.

Thanks,
Shane

#478845

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Ruben,

It seems that the language information is not being passed to the view since currently you have it set to language as a parameter.

What you need to do is go to WPML -> Languages and under "Language URL format" select "Different languages in directories" .

Please let me know if this helps.

Thanks,
Shane

#479026

Hey Thankyou Shane,
that has finally solved the issue!
While it had been working with language as a ?lang= parameter, changing it to a directory will be an acceptable solution.
Nice one