Skip Navigation

[Resolved] Parametric search don't work properly.

This support ticket is created 8 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 -
- - - - - - -

Supporter timezone: America/Sao_Paulo (GMT-03:00)

This topic contains 10 replies, has 3 voices.

Last updated by Adriano 8 years, 1 month ago.

Assisted by: Adriano.

Author
Posts
#402028

I am trying to: make a parametric search whit 2 search fields and 2 custom select boxes.

I visited this URL: hidden link

I expected to see:

Instead, I got: When i search on name it show all the results and not specific where a search for. And if i select the 3th select (zeeland) box it dont show nothing only if i reset then it work but not if you come on the page for the first time.

#402140

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

1)
Could you please try to delete your query filter as well as from View's filter section and try to add it again from "Filter" section using "New Filter" button and try to resolve your issue.

2)
Could you please try to resolve your issue by deactivating all third-party plugins as well as with the default theme to check for any possible conflicts with any of the plugins or themes?

3)
If #1 and #2 does not help, Could you please share edit view screenshot?

#402146

I try all the stepz but still not working seems to be a bug in the code.

#402176

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important. If you agree to this, please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP).

I have set the next reply to private which means only you and I have access to it.

#402223

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I tried to reproduce this issue with my test install but it's working fine for me.

On your test install - Yes, Indeed - there is some strange things happening. Even I checked by deactivating all third party plugins as well as with the default theme.

To debug your issue further I need duplicator and then I'll escalate your ticket to our next level support.

Could you please send us 1:1 copy of your site. You can do that by following next steps.

+ You can download the Duplicator plugin from here
=> http://wordpress.org/plugins/duplicator/

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/ ), please skip the following steps and just send me the installer file and a fresh package.

# Duplicator instruction
+ From WordPress plugin page, look for "Duplicator" and install it
+ Once installed, you get a new main menu "Duplicator"
+ Chose "Packages"
+ Click on the first button you find in the toolbar on the right ("Create Package")
+ Give it a name or leave it as is
+ Click on "Create Package Set"
+ Wait until the package is ready
+ Click on "Installer", then on "Package": the first one is just a php script, the second one is a zip file containing everything you need
+ Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)
+ Send wp-admin access details

I have set the next reply to private which means only you and I have access to it.

#402236

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thank you.

I'll escalate this ticket to our next level support. Please be patient, wait for a reply from them and they will get in touch with you as soon as possible.

#402771

Hello,

I’m Adriano, Toolset support lead and I have been escalated to this thread. I’ll give my best to help you to achieve your needs through Toolset components.

This is a matter of slug conflict. You have a page called Horeca but also has a post type called Horeca, so when you view this /horeca/ you are looking at the archive (WP files order). The data you see there are rendered by the Views archive (Horeca Archive) which doesn't accept filter elements.

What you can do to fix that is to create a page with another name and then insert the desired parametric search View.

Please let me know if you are satisfied with my reply and any other questions you may have.

Regards,

Adriano Ferreira

#402871

Hello Adriano,

That is the issue. Only if i change the slug the breadcrums dont work any more.
Do you have a solution for that?

Thanks,

Denis

#403070

Why don't you create a new page, another name? Unfortunately, there isn't another way, you can have the post type and a page with the same name in this case.

#403508

Thanks alot!

#403819

You are welcome.

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.