Skip Navigation

[Resolved] parametric search does not display the google maps correctly

The Toolset Community Forum is closed, for technical support questions, please head on to our Toolset Professional Support (for paid clients), with any pre-sale or admin question please contact us here.

This thread is resolved. Here is a description of the problem and solution.

This thread handles issues due to WordPress API Changes in WP 4.3.2.

It is not recommended to use this Thread as a general workflow reference

All issues described in this Thread are / where due to the WordPress API Changes in interaction with Types/Views, and should be fixed with the latest Toolset Plugins

This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

This topic contains 6 replies, has 2 voices.

Last updated by christianK-3 6 years, 1 month ago.

Assigned support staff: Beda.

Author
Posts
#323970

Hi Toolset,
we build up a site last year with a parametric search connected with a google map. With your nice help and own efforts we got all running good. Now suddenly the google map with the overview of all members does not receive any data and so it shows blue water in the atlantic and not the place it should display. The normal entry of each member work fine. What can be the cause of this issue? We did not touch the code...

Here comes the page: hidden link

thank you, have a nice day,

Chris

#323971
Bildschirmfoto 2015-08-10 um 13.48.52.png

screenshot

#324114

Thank you for contacting us here in the Support Forum

I apologize the delay here

This issue could (but does not have to) be due to the latest issues we have had with the relatively remarking changes in the WordPress ShortCodes API, which WordPress implemented in a security update (4.2.3)
https://toolset.com/2015/07/wordpress-4-2-3-fixes-a-security-problem-but-breaks-sites-with-shortcodes/

Now, to be sure to exclude this issue, could you confirm you are running the latest Toolset Plugin's versions?

You can find them here:
https://toolset.com/account/downloads

If the issue persists with the latest Toolset Plugins, a WordPress default Theme or our Starter Theme, and no 3rd Party Plugins, I would need some more details to help you solve this issue as fast as possible:

1. Can you recall the exact moment the issue was introduced?
(Update, install of another plugin, etc)

2. I would eventually also need to request temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important

3. An alternative is to submit me a site's snapshot.
We usually recommend the free Plugin "Duplicator" for this porpoise.

If you already know how Duplicator works
(http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions
hidden link
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Please don't hesitate to inform me in case the issue persists, and could you provide me the additional Infos,
and as well permit me to perform the required steps, if the issue persist?

Please also add some links to the Backend where you construct the Views, Content Templates, Posts etc in regard.

Thank you

#324399

Thanks for the Details

The situation is as I explain below.

1. Basically, we do support issues and troubleshoot issues within our Plugins, but we of course must always ask to use latest Updated versions, as many times Bugs are solved in newer Versions, and therefore solved.

Assuming it would be a Security Issue caused by our Plugins, and you would need to update the Plugin to solve this situation caused by Our Plugin, we would provide free updates.

2. Unfortunately, and I can't mention how sorry I am about this, this time the "fault" wasn't on our site.

3. It was (and is) not a BUG in Toolset Products causing this issue.

WordPress discovered a security issue affecting WordPress itself.
The WordPress release 4.2.3 fixed this security leak, but it also introduced significant changes to the WordPress ShortCodes API.

This, you might know, is not the "idea" of a Security Update, as those are automatic updates, and also usually they should NOT break any functionality or make CHANGES to the WordPress API at all.

This changes to the API where pushed 30 hours before the release of the Update to WordPress Core 4.2.3, leaving our Developers NO time at all to fix the issue surging by the API Changes in time.

A huge sprint of Support Forum request and Beta releases on our side was the result, where our DEV worked hardly to adjust our Plugins ShortCode parsing to the new WordPress ShortCode API.

As you can see form the above explanation, this issue was not caused by a definite mistake or error in our Plugins, but by a change in the WordPress API itself.

Given this, we can not offer a free update for our Plugins, which we would of course do when we cause the issues (or for important security releases).

This latest WordPress API change is a significant change in how ShortCodes are parsed. Our (and not only ours) Plugins needed to be partially rewritten.

Our Plugins now use a workflow which is adapted to the new WordPress API, and the issues surged by those changes are now not anymore present, but it is necessary to update the Plugins to it's latest versions.

I truly apologize that I unfortunately have to present the only available solution:
- To buy a new subscription for the Plugin(s), and update them to it's latest versions.

It is also to note, that we can not anyway support issues due to (perhaps) outdated plugins if those are fixed in newer releases. This is actually how our plugin is improved from release to release (by updates)

So you might perhaps even have other issues present in your install, which are "normal" bugs fixed in newer releases, and also newer features which are not included in your current version of Views.

A subscription would allow you to fully take advantage of those newer features, and of course it would fix the issues with the WordPress API issue mentioned.

I am truly sorry that I can not offer you a free upgrade.

You might, if you want, also consult the Sales department Responsible via this email:
hello@wp-types.com

There you will receive even more detailed explanations on this issue.

Please let me know if you have further questions regarding the issue mentioned in this Thread

Thank you for your patience.

#324548

Hi Beda, thank you for your kind words. I understand it completely and it's okay. So I will buy the upgrade and hope, that it will do its job after. If not, I'll come back again 😉

So you can close this topic.

Have a nice day, regards, Chris

#324661

I apologize deeply the inconveniences you are facing due to this issue, and thank you for your understanding.

Please feel free to update me here how it's going after you processed the steps suggested.

Please don't hesitate to inform me in case the issue persists

Thank you for your patience.

#329248

Hi Beda,
I bought the new version upgrading to the complete toolset - and it worked. Everything is displaying correctly now 🙂
We will tryout the toolset plugins and will see how we can integrate them in our workflow.
Thank you for your support and have a nice day!
Chris

The forum ‘Types Community Support’ is closed to new topics and replies.