Skip Navigation

[Closed] Paramatic Search not working anymore

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 1.07 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 21 replies, has 3 voices.

Last updated by Adriano 6 years, 1 month ago.

Assigned support staff: Adriano.

Author
Posts
#313988

I have created a view including the parametic search option. I would like to have the search and the result set on the same page. However, I'm always getting a blank page - no results are displayed.

I have recreated the view with my latest set of Views - no change in behaviour.

When I use the short code filter option to select - it is working.

hidden link

Access details are inside this thread: https://toolset.com/forums/topic/cred-forms-getting-fields-on-on-line-and-set-the-input-size/

#314027

Ahmed Ibrahim
Supporter

Languages: English (English )

Thanks for contacting our support forum .

Please try it with minimal environment , which mean only Toolset plugins and with one of our themes : https://toolset.com/account/downloads/#toolset-themes , or one of the default WordPress themes active.

Please let me know if that helps you.

#314193

I have used the Bootstrap theme - but no difference.

#314265

Ahmed Ibrahim
Supporter

Languages: English (English )

Thanks for your reply .

I need to request temporary access (wp-admin and FTP) to your site in order to provide a better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!
+ It'd be great if you give me an access for a test site where the problem is replicated.

+ Please specify the name of your view which includes the parametric search .

Best Regards.

#314663

Ahmed Ibrahim
Supporter

Languages: English (English )

Thanks for your data .

I couldn't log-in using your data , Could you please recheck them again , and I will activate the next reply as private to put the right credentials .

Best Regards .

#314672

Ahmed Ibrahim
Supporter

Languages: English (English )

Thanks I can log-in now , I have enabled the debug mode to see if any error presets but , no error came out , so I’d like to replicate your site locally. For this you'll need to temporarily install a plugin called "Duplicator" on your site. This will allow you to create a copy of your site and your content. You can provide me with the snapshot following these directions:
If you already know how Duplicator works ( http://wordpress.org/plugins/duplicator/ ), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
. From WordPress plugin page, look for "Duplicator" and install it
. Once installed, you get a new main menu "Duplicator"
. Chose "Packages"
. Click on the first button you find in the toolbar on the right ("Create Package")
. Give it a name or leave it as is
. Click on "Create Package Set"
. Wait until the package is ready
. Click on "Installer", then on "Package": the first one is just a php script, the second one is a zip file containing everything you need
. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big , you can also exclude the images if the file is very big )
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won't be able to log-in. You may delete the new admin account once the snapshot has been built.

I set a next reply as a private reply so you will able to provide a link to download the duplicator package.

Thanks and Best Regards

#315105

Ahmed Ibrahim
Supporter

Languages: English (English )

Hi stefan ,

You can send me the this files :

- wp-content folder (don't include the uploads folder if it have a lot of images)
- wp-config
- database dump.

you may use DropBox, Google Drive, or similar services.

I will set next reply as private in case you want to put the links

Regards

#315840

In addition I would like to ask how I can handle the pagination when search and results are split over two pages. I have activated the pagination, but it is not showing.

#316044

Hello Stefan,

Ahmed isn't available to handle this issue anymore, I'll take care from now. Is that site still online? I wanted to take a look there.

#317227

All right, I've identified the reason of that issue. When the Views parametric search is submitted, the URL is too long to your apache settings, it's returning the following error: 414 Request-URI Too Long (from cache)

Under Apache, the limit is a configurable value, LimitRequestLine. Change this value to something larger.

Please let me know if you are satisfied with my reply and any other questions you may have.

Regards,

Adriano Ferreira

#317269

What is the expected value for this URL Lenght?

I do see the same behaviour when I use the sort functionality of columns in my table views.

I will investigate this with my provider - still strange as this functionality was working in the past and the functionality remains working when you use a different search and results page

#317326

The length isn't fixed. Please see this with your hosting provider and see if you can increase it a little bit.

#317499

I have requested the details - waiting for there answer and see if it has been changed recently.

I do see the same issue popping up when you start to sort the columns within the table view. Also here, I'm getting a white screen.

The parametric search and sorting of columns was working fine with this theme and the same hosting provider. Since the latest update from Views, I do see this issue coming up.

#317789

That's because we implemented a hash for Views, it's being passed through wpv_view_count URL parameter.

#320979

This is the respond from my hosting partner - shared server configurations:

Under Apache, the limit is a configurable value, LimitRequestLine. Change this value to something larger than its default of 8190 if you want to support a longer request URI. However, note that if you're actually running into this limit, you are probably abusing GET to begin with. You should use POST to transmit this sort of data -- especially since you even concede that you're using it to update values. If you check the link above, you'll notice that Apache even says "Under normal conditions, the value should not be changed from the default."

The parametric Search is working when I use two pages

Page 1 (ID=704)

[wpv-form-view name="Opdrachten-zoeken" target_id="2656"]
<hr>
[wpv-view name="Opdrachten-zoeken" view_display="layout"]

Page 2 (ID=2656)

[wpv-form-view name="Opdrachten-zoeken" target_id="704"]

<hr />

[wpv-view name="Opdrachten-zoeken" view_display="layout"]

In addition to this, I do see also that the sorting based on table headers is also not working. Then I get the same long strange URL and a white screen.

Both functions were working without any problems in the past.

The topic ‘[Closed] Paramatic Search not working anymore’ is closed to new replies.