Skip Navigation

[Escalated to 2nd Tier] Pagination styling not getting applied

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Waqar 1 month, 1 week ago.

Assigned support staff: Waqar.

Author
Posts
#1714181

Tell us what you are trying to do?

I had styled the pagination (similar to what is shown in screenshot 1) on the slider created using Toolset View. When I insert the view on a page built with Gutenberg block editor and update the page, the pagination styling shows the first time I open the page on the front end, but when I refresh the page, the styling disappears and the pagination resets to default styling (as shown in screenshot 2). This problem is not present when viewing the page on a mobile device, or when inserting the view through elementor.

Is there a similar example that we can see?
Gutenberg block editor page: hidden link

Elementor page: hidden link

#1714401

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Mahmood,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot and reproduce this on my test website, I'll need to see how this slider/view is set up in the admin area.

Can you please share temporary admin login details, in reply to this message?

Note: Your next reply will be private and please make a complete backup copy, before sharing the access details.

regards,
Waqar

#1717043

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Rithvik,

Thank you for sharing the admin access and sorry about the delay in getting back on this.

I'll be performing some tests with similar views and settings on my test website and will share my findings, as soon as this testing completes.

Thank you for your patience.

regards,
Waqar

#1718117

Alright, do let me know what you find. Thank you!

#1720747

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Rithvik,

Thank you for waiting and I apologize for the delay in getting back on this.

During testing on my own website with a similar view and settings, I was not able to reproduce this issue and the pagination styles loaded correctly each time.

I did notice that your website has some cache and code optimization plugin active and it would be interesting to test this with all non-Toolset plugins disabled.

In case the issue still persists, I'll need a clone/snapshot of your website so that it can be investigated on a different server, without affecting the actual website.
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

Please let me know how it goes and I've set your next reply as private.

regards,
Waqar

#1734333

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Mahmood,

Thanks for writing back and for sharing these details.

I've downloaded the duplicator package and will be performing some tests on my own server.

I'll update you, as soon as this testing completes.

regards,
Waqar

#1736025

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Mahmood,

Thank you for sharing the duplicator package.

During testing, I noticed that the pagination styles are loaded correctly for visitors and logged-in users alike, if the "Cache View" option is disabled from the view's settings.
( screenshot: hidden link )

I'm currently trying to reproduce this on a clean install, but can you please confirm this observation about the "Cache View" option from your two websites?

regards,
Waqar

#1736319

Thank you so much for the help, turning off the cache view did fix the issue on both the websites. It's very unfortunate that this was what caused the problem. Please do let me know if you are able to reproduce it, if not, please help me understand what the underlying issue is and why this could be occurring only on my websites. I cannot have this reoccurring in the future, but I also feel that I should be able to use the features I have paid for and turn on the cached view. Thank you again for the help Waqar.

Also it would be helpful if you could also tell me what the cached view option does and if it is ok to use it (under normal circumstances) alongside a regular non-toolset caching plugin.

Best,
Mahmood

#1738077

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Mahmood,

Thank you for waiting and for confirming the results.

After testing on my own website, I was able to reproduce the issue, and here is what is happening:

If the “Pagination” block in view is set to use “Previous/Next page link” style and for previous and next text "lower-than" and "greater-than" characters are used, with the “Cache View” option enabled, any styles added to the “Pagination” block through its “Style settings” are only applied to the output once. For all subsequent reloads and refreshes, the pagination block’s custom styles are not loaded.

I've shared this report with the concerned team and will keep you updated through this ticket. For now, if you absolutely have to use the "lower-than" and "greater-than" characters in the pagination, you can keep the view's cache option disabled.

When the =“Cache View” option is enabled, it saves a pre-generated copy of the view's output, when the page with the view is loaded first time on the front-end, after any changes to the view have been saved/updated. As a result, processing/loading time improves on the subsequent reloads/refreshes. The Toolset Blocks plugin manages this cache on its own, so it can be enabled even if another caching plugin is active as well.

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar