Skip Navigation

[Resolved] Pagination of post type

This support ticket is created 4 years, 4 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Christian Cox 4 years, 4 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#804589
screenshot-m25movers.co.uk-2018.05.03-16-57-50.png
screenshot-m25movers.co.uk-2018.05.03-16-57-44.png

I am trying to: Show a post type using pagination to show 5 per page. It shows the first 5 but not shows the second page as empty, when there are 8 posts there. Also when you go to the second page and try to go back to the first, the first is blank also.

Link to a page where the issue can be seen: hidden link

However the page needs a login, can I email it to you?

I expected to see: 1st page with 5 existing orders, 2nd page with 3.

Instead, I got: 1st page with 5, 2nd page with none.

#804871

Sure, I can take a look. Private reply fields are active here.

#833303

Sorry for the delay, but I am not available on Fridays (see my hours here: https://toolset.com/forums/users/christian-c/). I logged in and don't see anything obviously wrong here. The View appears to be set up correctly for filtering and pagination. Can you try the following troubleshooting steps?
- Temporarily activate a default theme like Twenty Seventeen, then deactivate all plugins except Types and Views. Test again.
- If the problem was resolved, reactivate your theme and plugins one by one until the conflict is revealed.
- If the problem was not resolved, then I'll need to take a closer look. I can install the Duplicator plugin and create a clone of your site so I can run additional tests without affecting the live version.

Let me know what you find out and we can go from there.

#867830

Hi Christian,

Ah great thank you for letting me know when you're around.

I have done this and nothing got it working. Could you duplicate the website and look into it further for me please?

#868249

Okay let's try to narrow things down a bit. As a test, please duplicate this View and remove the accordion shortcodes from the Loop Output editor, and remove the accordion_item shortcodes from the Templates for this View. Then replace the current View with this new test View temporarily. It's not going to look right, but it should be functional and you should see results on each "page" of the View. Let me know what you find out.