Skip Navigation

[Closed] order post in archive

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Christian Cox 9 months, 2 weeks ago.

Assigned support staff: Christian Cox.

Author
Posts
#2020583
Schermata 2021-04-14 alle 12.35.12.png

I set up an archive page:
hidden link
I have problems with the order of posts.
I have set "menu order" order but a different order is displayed each time I load.
why?

#2021057

Hello, can you try these troubleshooting steps first to rule out any potential conflicts with other components of the site?
- Temporarily deactivate all custom code snippets in Toolset > Settings > Custom Code
- Temporarily switch to a default theme like Twenty Twenty One
- Temporarily deactivate all plugins except Types (if active) and Blocks
- Test the archive again
- If the sort order is now correct, reactivate your custom code snippets, plugins, parent theme, then child theme, one-by-one, checking the order each time you activate a new component. Try to isolate one component responsible for the order problem.
- If the order is still incorrect, try a different order like post date instead of menu order. Does a different sort order work correctly, or is the order by post date incorrect as well?

Please let me know what you find out from these troubleshooting steps and we can go from there.

The topic ‘[Closed] order post in archive’ is closed to new replies.