Skip Navigation

[Resolved] Notification Emails are buggy.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 7 replies, has 3 voices.

Last updated by Luo Yang 2 years, 6 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#1245963

Please see this ticket: https://toolset.com/forums/topic/new-post-notification-emails-are-not-functioning/#post-1245924

I am unable to get this matter resolved and need any other tech support person who is willing to look at and see the issue. THIS IS URGENT. I have waited too long and the person handling this issue seems unable to understand the problem at all.

You already have the entire Duplicator package, complete access to the site, Debug information and I have verified that tech support has already installed an entire copy of this website.

THIS IS CRITICALLY URGENT. THIS IS AN ACTUAL PROBLEM WITH TOOLSET CRED FORMS PLUGIN. I NEED IT RESOLVED NOW!!!!

#1246280

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

There might be a time difference between us, and I have answered that ticket:
https://toolset.com/forums/topic/new-post-notification-emails-are-not-functioning/#post-1246271

It might be a server problem, and I don't see the same problem in your website, please follow up above ticket, check if it is a HTTP2 problem, thanks

#1246295

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Let me just comment here that I have read through the other ticket in its entirety, and I have visited your site and checked the backend where I can see the latest test "Filtered email" submission from Luo, which includes the random string field, and the corresponding notification email in the SMTP log, which includes that random string.

I looked at the publication time of the filtered email post (01:10 UTC-5) and confirmed that the time of the notification email was the same.

So everything that is expected to work appears to be working.

You are, of course, welcome to request a different supporter, but Luo is technically excellent, and any other supporter would be following the same steps as I can see he has followed in the other thread.

#1246733
Screen Shot 2019-05-21 at 3.00.07 PM.png
Screen Shot 2019-05-21 at 3.00.35 PM.png

I just proved that the problem exists and continues and have uploaded images showing the problem.

I just registered a totally new email: tp@bongo.cc. I did it at 2:43 pm, May 21. NO CONFIRMATION EMAIL. NOTHING IN EMAIL LOG. NOT WORKING!!!

SEE IMAGES: Email registered at 2:48pm. Email log at 3:00pm DOES NOT SHOW ANY NOTIFICATION for tp@bongo.cc. NOT WORKING!!!!!

I have included my computer clock in those images for comparison.

#1246807

Nigel, you have read that Luo has submitted an email. This is not true. I want you folks to add email domains to the array of allowed domains editable in functions.php of the child theme. Feel free to add any domains you need in order to submit your own form and see that you will NOT receive the correctly configured notification.

Luo has simply seen some activity in the log that he has confused with the correct function. The actual user notification has the subject line ‘Try Nutanix POC Nomination Link’. The rest of the records in the email log are test emails sent from either the SMTP plugin or the test link within the CRED plugin and DO NOT have anything to to with this problem.

If you look at the current list of Filtered Email posts you will see that NONE of them have produced this notification. This can be confirmed by looking at the log time stamps and comparing those to the post time stamps.

Please actually test this issue for yourselves. Edit the array of allowed email domains in the child theme functions.php file and add whatever domain(s) you would like. Then, complete the form at trynutanix.com/email-entry. You will NEVER see the notification arrive in your inbox. Arriving at any other conclusion without doing what I have done and actually verifying this for yourselves will only serve to protract the current, pointless and time-wasting back-and-forth.

This is real, persistent and is causing me great expense and trouble with 6 clients at the moment. It seems like it should be straightforward to diagnose and correct, but I keep being told that it isn’t happening.

#1246890

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have added our email address domain name in your theme file functions.php, please check the details here:
https://toolset.com/forums/topic/new-post-notification-emails-are-not-functioning/page/2/#post-1246880

#1247199

Thanks, Luo. I will continue this ticket over there & you can close this one to prevent confusion.

#1247489

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

As your request, close this ticket.