Skip Navigation

[Resolved] No paragraph breaks in post content with blocks based template

This support ticket is created 4 years ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 9 replies, has 3 voices.

Last updated by davidM-17 3 years, 11 months ago.

Assisted by: Waqar.

Author
Posts
#1529247

Hi Toolset Support,

I created a content template for books using Toolset Blocks. I see that the post content output doesn't have any breaks between paragraphs. For example:

hidden link

I have seen in the old editor a place to pick manual paragraphs or auto paragraphs, but there isn't anything like that that I can find the block editor. I have use both classic and blocks in the settings and it is possible I checked manual paragraphs when starting out before going into the block editor, but now there is no way to get back to the classic interface ... if that is the issue.

Suggestions for fixing this would be appreciated.

Thanks,

David

#1530455

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi David,

Thank you for contacting us and I'd be happy to assist.

I've checked the content of the page that you've shared and I do notice the paragraph breaks.

Have you managed to add some changes after writing to us? In case the issue still persists, you're welcome to share temporary admin login details, along with the exact steps to see the issue.

Note: Your next reply will be private and please make a complete backup copy, before sharing the access details.

regards,
Waqar

#1532609

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi David,

Thank you for sharing the admin access.

I noticed that the content on your post "Burn the Dark by S.A. Hunt" is saved in the classic editor without the paragraph tags as part of the content.

For content like this, you can replace the "Single Field" block with the "Fields and Text" block and insert the shortcode [wpv-post-body view_template="None"] and the paragraph tags will be automatically applied to it.
( ref: https://toolset.com/documentation/user-guides/views/views-shortcodes/#wpv-post-body )

To display different content based on a tag, there is no feature to automatically assign different content templates. However, you can use conditional display feature, to show or hide a specific part of the same content template:
https://toolset.com/documentation/user-guides/views/conditional-html-output-in-views/displaying-taxonomies-conditionally/

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#1532963
change-content-template-to-book-single.png
page-with-book-single.png
book-single-template-in-editor.png

Hi Waqar,

Thank you for taking a look and for the further information. I'll go ahead and finish up my templates but could you please explain the paragraph thing a bit?

- When I use the old classic Toolset Editor for the content template the paragraph breaks show up. I confirmed this by switching that book back to the Book Single template that was created back in 2017. Attached are some screenshots of that.

- When I don't use any content template (just the theme) the paragraph breaks show up. I don't believe there is a theme setting on whether to add manual paragraphs or not. I think this is the way it just works on all themes.

- Are you saying that if I used the block editor for the content that the content would show the paragraph breaks in Toolset Blocks?

- Or is this a quirk of the Toolset implementation of the Content field in the blocks editor?

- Or something else?

If this is related to the option in the old classic content template editor to use manual paragraphs or auto paragraphs then perhaps that is a feature / checkbox option that could be added to the blocks version?

Thank you also for the suggestion regarding the using conditionals to display the fields for the audiobook tour records. It is a good idea, but in this case there are a lot of fields and the content template for the audiobook tour doesn't have a sidebar ... so it doesn't seem like an easy solution. I'd like to suggest it as a feature please. Beaver Themer and Elementor Pro have the option to assign a template to a content type + a category or tag.

Thank you for your patience. I am drilling down on the issue because I know that the block feature is new and I want to make sure I understand it and if there are any issues with it that we identify those so they can be addressed.

Best regards,

David

#1533099
book-with-test-template-on-front.png
book-with-test-template-in-editor.png
output-mode-when-creating-template.png

Hi Waqar,

So I have been able to recreate and trace the problem.

When you first create a content template with the Toolset settings for both / either classic or block editor you have the option for manual paragraphs or auto paragraphs. See screenshot. As I mentioned in my original post, I thought I might have picked manual paragraphs when I created the content template the first time.

So I just created a test content template and chose auto insert paragraphs and the paragraph spacing is shown on the front correctly. See screenshots.

Once you create a content template in Toolset Blocks you cannot change that setting. I think there should be a way to access that setting again if needed. I will recreate my content template with the auto insert paragraph setting to fix my issue, but I suggest it would be good to have this addressed for the next person / next time.

Thank you,

David

#1536807

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi David,

Thank you for sharing your detailed findings and feedback.

We're already internally reviewing the current implementation of single field block's post content body output, more specifically it's handling of auto-paragraphs.

I'll keep you updated with the progress through this ticket and appreciate your report.

regards,
Waqar

#1541563

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi David,

I've heard back from the development team and at the moment the single field block's post content body feature is designed to be used with the content that is generated using the Blocks editor, which saves the paragraph tags as part of the content in the database.

For displaying the content that is generated through the classic editor and doesn't include paragraph tags, it is best to use the shortcode [wpv-post-body view_template="None"], which will automatically apply them.

If you'd like to see an option to control the auto-paragraphs in the output of the single field block's post content body output too, you're welcome to submit this as a feature request at:
https://toolset.com/home/contact-us/suggest-a-new-feature-for-toolset/

regards,
Waqar

#1542073

Hi Waqar,

There is a lot of content created with the classic editor and I'm not sure that supporting old content is a "feature". It is good there is a work-around. Thank you for letting me know. I'm trying to move away from shortcodes so will have to think about what I want to do going forward.

Best regards,

David

#1545385

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi David

Waqar is on vacation for a few weeks, looking at this I'm not sure there is more to do here, are we able to close?

#1545607

My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.